Showing results for 
Search instead for 
Did you mean: 

Virgin Go app stepped Woking on my iPad

Tuning in

The Virgin Go app has suddenly stopped working on my iPad.  It was working fine up until yesterday now when I open it up and select a channel, I get different error messages, sometimes I get the pop up telling me to register my device (which I’ve tried, doesn’t work) and another error is ‘Not available - sorry we can’t play this at this moment - 1102’.

I’ve tried uninstalling and reinstalling the app, logging out and logging back in. It works fine on another iPad in the house. 

I can see others are having problems with app, is there a fix?


Tuning in

Just tried to log in from a browser and got a different error message  ‘Not available - sorry we can’t play this at this moment - 3016’.

Thanks for reaching out to us @Rag19, and a very warm welcome to our Community Forums!

Sorry to hear of the issues you've been experiencing with the TV Go services on your iPad, can you please confirm that both the iPad and TV Go application on the iPad are currently running the latest software versions?

In addition to this, have you attempted to use the TV Go services on an alternative device since this fault emerged?



Yes both are running the latest software versions and TV Go is working fine on an alternative device (different iPad).

Thanks for confirming this @Rag19 

Ensure that there is no other devices using the TVGO app or have it opened in the background as this might cause this issue. 

If you're sure no other devices are using or have the app open, can you see if the device is registered and if so try removing the device and re-registering this to see if that works? 

Customers can have up to 5 different compatible devices signed up to the TV Go service and use the app at one time, with the ability to make adjustments to their registered devices 3 times in one month. Instructions on how a customer can register a device or replace a registered device can be found here.

Here to help 🙂
Virgin Media Forums Agent

Yes I’ve done the re-registering device and it made no difference.

This is a really slow way to try and resolve a problem!

I’ve spoken to a virgin media rep on Wednesday over chat from the website,  who said they had escalated my issue and I would get a phone call. I’ve had nothing.

I can see from other posts that other people have had this same issue, how has it been resolved previously?

Hi @Rag19, thank you for your response.

We're sorry to hear you haven't received the call back you were promised 😔

In order to look into this for you further, we'll send you a private message on here. Look out for the envelope in the top right-hand corner.

If you're on a portable device with a smaller screen, click on the icon in the top right-hand corner and select "messages" from the additional menu options.