cancel
Showing results for 
Search instead for 
Did you mean: 

TV go Registered devices limit

Mechrior
Joining in

I recently started using the Virgin TV go website to watch Stargate SG1 in my office.

The problem is EVERY TIME i load firefox up it tells me to re-register a device! This has now come to the point it is telling me to wait until November 1st to change a device.
This PC is the ONLY device I have tried accessing the service on. it ALWAYS takes me to the HTTPS:// version of the site, and now I can not watch anything from my saved programs.

I have set virginmedia.co.uk and .com to not clear cookies or cache, and also the virgintvgo.virginmedia.com to do the same but when logging in today it has still told me to register as another device. MY IP did not change, my DNS did not change, the computer was left on from the last time I used the service, and i even left the browser window OPEN so it would not clear accidentally.

Please sort something or stop it requiring cookies AND cache to verify that I am accessing a service I pay for.
I understand the need for me not to be using the service from somewhere outside my registered devices but this is the ONLY device the service is "registered" to and it NEVER seems to stick even with the browser being left open.

Please help as I have now lost access to part of my service.

Thank you.

10 REPLIES 10

Arissa_H
Forum Team
Forum Team

Hi Mechrior 👋🏼.

Thank you for posting, welcoming you with big virtual arms onto the community forum 🤗.

Sorry to see you are having this issues with your TV Go on your web browser and are having to clear cache and cookies ☹.

I understand you are using Firefox but is there any chance you can try this on Edge or Google browser? 

Is there any other device you can use to see if this will appear on the other devices?

Do you still have to do this when using it by our app? 

Let us know we want to help. 

Ari - Forum Team


New around here? To find out more about the Community check out our Getting Started guide


I have NOT been clearing the cookies and cache for firefox, I stated that I had set all virginmedia sites to deny this in my previous post.

I also can not try ANY other devices or browsers at this time as I already stated I am locked out of registering any other devices untill November 1st.

If you are talking about the phone/tablet app that would not help my situation as that is not the intended way I want to use the service.
If you are talking about the windows app then it was REMOVED from the windows store some time ago, and I would have thought that you would know this.

Hi Mechrior, 

Thanks for coming back and clarifying things for us. 

Rather than having TV Go as an exception, can you ensure that the automatic deletion of cookies is off to see if this makes any difference. 

We need to see if this is a browser issue so as the device changes have now reset, can you try on another browser for us?

Where Arissa was talking about the app, she was referring to an Apple or Android device as the app is available on both these platforms. If you don't have one of these devices then just let us know. 

We've recently been made aware that there could be new settings on the browsers that is causing this, but we need to make sure the cookie clearance is looked at as the first step. 

Keep us posted on how things are. 

Thanks, 

Kath_F
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


I loaded TVGO through google chrome, added a new device, and loaded SG1 played it for a few seconds, then closed google chrome.
Upon loading google chrome again and going back to TVGO it loaded but now told me that:
"Oops - there are too many devices watching TV on this Virgin TV Go account at the moment. Close the app on one of your devices and try again"

I repeated these steps on Mozilla Firefox and recieved the same error message from the same steps.

It seems to happen if I do not go back to the main screen of the virgin TVGO website before closing it. If I close the tab or browser BEFORE going all the way back to the main screen, it does not register the video as being closed.
If I make the step of using the arrow in the top left of the screen to go back to even just the screen that lets me choose the episode/season it seems to remember the device is the right one.

Have now opened and closed multiple times and seems to be working fine.

I also installed Virgin TV Go on my Samsung tablet.
The app there works without any apparent issues right now but as I said I would not normally be watching the items there as my desk has much bigger screens.

I would prefer not to have to keep unwanted cookies after I close firefox and just have the virgin site set as an exception like I already had it.

Please let me know if there is anything else you would like me to try?

Kain_W
Forum Team (Retired)
Forum Team (Retired)

Thanks for the response on this matter Mechrior,

Just from what's been explained, we can try to reset all registered devices if you'd like?

Are you able to remove any devices at all from your side?
Let us know,

Kain

Sdfitz
Joining in

I have been using the virgin go app on my Lenovo tablet and everytime it is asking me to register the same device. It has used all the 3 changes putting the same device and now I can't use it till 3rs December 

Hi there @Sdfitz 

Thank you so much for your post and welcome to the community forums, it's great to have you back. 

I am so sorry that you have been facing this issue with your TV Go devices, can I ask if you are clearing cookies and cache or have them set to clear automatically? 

We can reset the devices limit for you if you would like, just let us know and we will pop you a pm to do so. 

Hi it's on the app and it's set to default. Yes I would like it reset please 

Hi can you pm me please