cancel
Showing results for 
Search instead for 
Did you mean: 

Very slow broadband speed

AndresAlvarezM2
Just joined

Hello all,

I recently joined Virgin Media and my plan is the 1 Gb one. After a couple of days, I noticed that my upload speed is very slow (less than 1 Mb per second).

I have tried turning it off and on and factory resetting my router without much success. This is a Hub 5 Router, and previously I was using a Hub 3 from the previous account, and that upload speed was fine. Can anybody help me, please?

1 REPLY 1

Kath_F
Forum Team
Forum Team

Hi AndresAlvarezM2, 

Thanks for taking the time to contact us via the Community. It's lovely having you on board with us in the Forums.

We're sorry to hear you're having an issue with your upload speed since moving to the 1GB connection. I can see you've also contacted us via X. As we work across all Social Media channels, please stick with this method of communication so we can keep all the information in one place. 😊

Checking things here, we can see that there are a few issues with your power levels, and checks on the cabling also show issues. We can also see a very high number of disconnections in a small amount of time so as a result, we will need to arrange an engineer visit. I just need to confirm the address to ensure we are booking the visit on the correct account. I have sent you a direct message to allow us to do this with you in a private space. If you are using a PC/Laptop then you can just click on the little ✉ at the top right-hand side of the page to access your inbox. If you are on a mobile/tablet device then instead click on the little circle icon in the top right then select 'Messages'. 😊

Thanks,

Kath_F
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs