cancel
Showing results for 
Search instead for 
Did you mean: 

Google Drive downloads failing

mrsnooch
On our wavelength

Hi, I am on the 1Gig service. I have the VM hub in modem mode, and then a TP-Link AX20 for router purposes. I have tested the following issue both in this setup, and without the AX20 in play, and it persists in both.

I do a lot of video editing and frequently am downloading 20GB+ files from Google Drive. These past 2 weeks I have noticed the downloads just fail at a random point. Resuming isn't an option without a ridiculous manual work around that isn't practical for me to do for the amount I download. 

We had an engineer out at the weekend and he checked and all the levels were fine according to him (he did show me his mobile device and everything had green arrows next to it). I have since tried factory resetting the VM router, but no luck. The problem persists on both my Windows PC and Macbook, both using wired connections as well.

As far as I can tell, this is the only service whereby this is happening. The fails might indicate drops in the connection, but I do not see this in any other situations. I also game a bit and have not seen this happen there, where it might be more noticeable.

Any ideas why Google Drive in particular might be failing, and why all of a sudden?

Thanks

EDIT: This happens on any browser, and I have even created a Python3 script that will check a particular Google Drive and download the files for me, so it's not restricted to a browser, and in turn, browser extensions etc.

16 REPLIES 16

legacy1
Alessandro Volta

A Download Manager in the browser that does not resume many times is a bug its not a video.

---------------------------------------------------------------

mrsnooch
On our wavelength

Possibly, but the original issue remains, the downloads fail at some point during the download when they never used to before 2-3 weeks ago

Thanks for the reply on the forums @mrsnooch. 🙂

I'm sorry to hear about the issues with the Google drive downloads. 😞
I've checked on my end too and no issues are present. 😕
Have you reached out to Google themselves to possibly see what the issue may be?
Does this happen on multiple devices as well?

Kind regards,
Ilyas.

Ilyas_Y
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Long shot but you could try using google dns instead of the virgin ones. Many weeks ago I was having weird issue on ios with web pages struggling to load. It was only on ios not windows machines. Anyway I changed the dns to google ones and all was well with the world. Whatever it was was temporary as I recently reverted back and all ok. It may not work but give it a try, nothing to lose

Thank you I'll give this a shot!

I'm having the same issue. I'm not able to download files from Google Drive, and it's running exceptionally slow and lagging working in Google Drive. I'm confident its something to do with Virgin internet as I've switched to my mobile and I have no problems. Can you help? 

Hi @garycw, thank you for your post.

We're sorry to hear about the issue you're experiencing 😔

When did you first notice this? Also, have you tried following all the advice provided in this article here

Please pop back to us at your earliest convenience.

Regards,
Daniel