cancel
Showing results for 
Search instead for 
Did you mean: 

Connect App cannot find hub

ianp1965
On our wavelength

Had a new Hub4 installed 2 days ago. All my devices reconnected fine, but trying to use Virgin connect App but it cant find the Hub. Tried all the advice the app gives, (android) have cleared cache and data, have enabled the location.

Really want to get it working as we have a wifi weak spot. 

3 REPLIES 3

Client62
Hero

Just buy a Wi-Fi repeater or Mesh you could have a solution in place today.

ianp1965
On our wavelength

How will that help me connect thier app to the hub?

Why should i pay for repeater when im entitled to free ones from Virgin

Hi Ianp1965 👋🏼.

Thank you for posting, welcoming you back onto the community forum ☺.

Sorry to see the connect app is not finding your hub ☹.

Have you tried doing a reset on your hub and then seeing if it appears on your app?

Are you able to see everything else as normal on the app?

Let us know we will do our best to help you from here. 

Ari - Forum Team


New around here? To find out more about the Community check out our Getting Started guide