cancel
Showing results for 
Search instead for 
Did you mean: 

Virgin Media Connect App doesn't work

kamranbaig
Tuning in

Virgin Media Connect App stopped working after some days of installation of Hub-5. I've rang and gone through different troubleshooting methods been told my Virgin Media technician but nothing work. 

I've raised a complaint some weeks ago and Virgin Media didn't bother to ring or reply. I've rang again and been told there is a problem with App, Virgin Media is trying to sort it out.

It's more than a month but there isn't any solution yet?

8 REPLIES 8

Ilyas_Y
Forum Team
Forum Team

Hey there @kamranbaig 👋 Thanks for reaching out to us and a warm welcome to the Virgin Media forums!

I'm sorry to hear about the issues with the Connect App 😞
May I ask if you're able to send a screenshot of the issue itself that is occuring?

Are you able to try another device and see if the same issues occur on there as well?
Are you able to ensure that the Connect App you have is on it's latest firmware as well as your operating system?

Let us know.

Kind regards,
Ilyas.

Ilyas_Y
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


I have uninstalled/installed the app many times since I have raised the complaint last year December-2022. I have also reset Hub some time but nothing changed.

Please find screen shot (App can't find Hub).AppError.jpg

I have installed this App on other iPhone but it's still not working.

Reece_MH
Forum Team
Forum Team

Hi kamranbaig,

Thanks for confirming that. I'm sorry things still aren't working. Please ensure you are connected to your Home Network, and don't have any 3rd-party equipment (such as a Router) connected, and ensure your Hub is in Router Mode. The app also won't allow the connection if you're on a Guest network, VPN or Mobile Data. 

If, after checking those, you're still having the problem, try clearing the data within the Connect App. These steps will help you do that: 

For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. 
 

For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 
 

If this also fails then please be aware that our teams are currently aware of an ongoing issue, that is causing the app to not recognise the Hub in a minority of instances. The team are investigating and working on fixing this as a high priority. 
 

Thanks, 

Reece - Forum Team


New around here? To find out more about the Community check out our FAQ


I've tried everything but it's still not working.

It's more than a month and there isn't any solution of the problem with the App?

We do appreciate your frustration with this kamranbaig.

We are still investigating this. 

^Martin

Scottdno1ok
Tuning in

I had the same issue with my app and it was great for using to check for WiFi dead zones and to turn of my kids WiFi on any single device. This was until I changed my living room tv and virgin box positions and had to reroute all the cables from my tv, Amazon fire stick and the virgin box to hide them all inside trunking and put the entire set up out of view in a cupboard. Then I started to get all types of issues with the app because I had to obviously turn the router WiFi pods  and tv boxes off and I managed to get it all working again about 2 months ago but then I updated my iPhone and it’s doing the same thing all over again and I can’t for the life of me remember what I done the last time to correct it. I do remember it took me hours and hours to get the answer and virgin were no help at all I had to find the solutions myself online 

Macme
On our wavelength

I have identical issues with the App, after lengthy calls to the help desk now been referred to the IT department, I have finally received my first booster no instructions on how to install, again after lengthy calls I was asked to use the VM connect app to resolve all my issues. Another clear demonstration of  call centre that are just not joined up, thank goodness for the members forum for advice now all working, you just have to leave it overnight it then connects to the hub. The sad thing when the broadband is working it’s a brilliant service.