Showing results for 
Search instead for 
Did you mean: 

VM Connect App and Router access

Joining in

Over the past few weeks our internet has slowly become more and more problematic, to the point where Virgin sent me a new hub which arrived yesterday. The hub installed absolutely fine, however this has naturally changed the hub name and password. This now means that I’ve had to Reconnect all of my devices, which is a small price to pay. 

However, upon realising that the majority of my devices (CCTV, Doorbell, Smart gadgets etc) Work on 2.4 I loaded up the connect app to enable dysfunction and also the guest Wi-Fi. The app is unable to find my hub Which means I cannot make the changes and also cannot connect any of my devices, including security devices. I have followed all of the steps online, including several others that I’ve had the exact same issue elsewhere On this website, To no avail. 

When using the Route it allows me to change the initial password however when I login, I just get a blank white page, Not helpful at all. I have tried multiple other devices, including a desktop computer iPhone and android And none have worked.

I have spent several hours today on the phone to virgin to try and get this issue fixed and I’ve got absolutely nowhere. I’ve completed the Reset on the hub using the pinhole for 60 seconds and it’s still isn’t working. I repeat this is a new hub that was delivered yesterday. 

Is anyone able to help me get either the app or the online page working for me to enable 2.4 And the Wi-Fi name and passcode. This is turning into a complete nightmare for result. I’m currently having to have my laptop rebuilt as well as the Internet drops out during a key update again. 



Sounds like you have a Hub 4 with a failed menu.

A 60 second press of RESET & then leave the Hub powered on may restore the menu to working order.

Forget the Connect app is is not needed & more trouble than it is worth.

If possible use the Hub menu to make the required Wi-Fi changes. Set the new Hub to offer the same Wi-Fi + Passwords as the previous Hub and then your devices will be able to re-connect.

If the Hub menu does not restart, call VM and report this Hub as another dud.

The issue continues with another twist this morning. We’ve had a Virgin technician arrive to fix a broken tv box upstairs (yep another thing broken), who has had a look at the new box that arrived 2 days ago. He also couldn’t get the menu working or the app and decided to swap the modem AGAIN. Once it was installed and in working order we tried to menu/app and it still isn’t working. He has now left with the old “leave it 24 hours and report it again”.


The ironic moment was when he rang the doorbell and was left outside because it doesn’t working because of the WiFi! 

So we have a 2nd new modem now and we are no closer to fixing the issue. So frustrating. 

Hello cleavel93


Sorry to hear of the Hub, connection and app issues experienced, we understand the concern and appreciate you letting us know via the forums. Welcome to the community.


It's been a few days since the visit and replacement Hub, has there been any progress or improvement on this during this time? As mentioned, there is a known issue with the Hub 4 and the Connect App which is currently being worked on, this impacts the app's ability to connect to the Hub.


You can still do this via a browser on nay device and the IP address into the address bar and using the settings password on the sticker on the Hub.




What is written above is incomplete / incorrect.

Router mode Hub 4 appear to fail in the following way :

1) At entering the password results in a stuck blank / white screen. i.e. no Hub 4 menu.
2) The VM Connect app now fails to connect to the VM Hub 4
3) Any VM Pods become off line.

Hub 4 customers using Modem mode are not reporting the menu failure fault,  ( for modem mode the Connect app and VM Pods are not part of the installation ).   What some Modem mode customers have reported is a recent ( this year ) software update. One can not help but wonder if that update is the root cause of the current stream of Hub 4 Router mode issues.