cancel
Showing results for 
Search instead for 
Did you mean: 

Local DNS suffix is now cable.virginm.net

ajdunlop
Tuning in

4 days ago I received and setup my Virgin Hub 3.

I then put the Hub 3 into modem only mode and connected this to my Linksys Velop mesh WiFi router.

Everything was working fine until the early hours of this morning when lots of things on my local network stopped being able to talk to each other. It looks like this is to do with their local host name suffix changing from .local to .cable.virginm.net.

I don't want this as I have lots of things configured to look up each other with the .local suffix and some devices are still responding on this. I also don't want to have to go around changing things on all my devices if I can help it.

I've updated the local network DNS settings to point at Google's DSN 8.8.8.8 and 8.8.4.4 but that doesn't seem to have fixed anything.

9 REPLIES 9

ajdunlop
Tuning in

Forgot to day I've also turned off the Parental and Virus protection in My Virgin Media and restarted everything but hasn't helped. This was suggested on posts talking about the Advanced Network Error Search.

Adduxi
Very Insightful Person
Very Insightful Person

The Hub in modem mode is just a bridge, so the Parental and Virus stuff does not work in anycase as this is bypassed by your own Router.  Just double check your Hub 3 is actually in modem mode?  I would be tempted to do a full 60 second pinhole reset on the Hub and put it back in modem mode afterwards.  This should all be done with a direct wired connection.

Your Linksys should be setup with the DNS of your choice and this should replicate to all your connected devices.

60 second factory pinhole reset as below;
Remove any ethernet cables from the Hub and hold the pinhole reset switch for 60 seconds. Do NOT reboot the Hub, just let it do it's thing. Note you will need the passwords from the bottom of the Hub afterwards, so make sure they are legible. NOTE this will remove any custom settings you may have set in the Hub, and they will all have to be setup again.

 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Client62
Legend

Use of Google Public DNS on your Router totally bypasses the VM Web Safe ( Child Safe & Virus Safe ) function.

The .local addresses are used on your home intranet LAN which is hosted by your 3rd party Router,
I would suggest that was the place to start investigating for any config changes. ( e.g. Wi-Fi AP Isolation )

The "cable.virginm.net" can only be seen from the public internet for the Hub public IP hostname,
e.g. via https://whatismyipaddress.com/ 

I've tried the restart and I am still seeing some of my devices responding with hostnames that end in .cable.virginm.net although many of them seem to be also responding to pings on <hostname>.local as well as <hostname>.cable.virginm.net

 

I can't find any setting for AP isolation.

My router does seem to be setting cable.virginm.net as a DNS search domain on my devices and some of them are responding with that suffix in their hostname when I do an nslooup on their IP address. Even the router itself does.

legacy1
Alessandro Volta

So your local DHCP server by Linksys Velop is sending out the DNS suffix is as cable.virginm.net when received on the WAN DHCP?

Could this be why VM is doing router mode so that the local DHCP server does not send out this DNS suffix?

 

---------------------------------------------------------------

Yes it looks like it is passing on this suffix from the Hub on WAN to the local DHCP.

Not sure I under stand your 2nd question.

legacy1
Alessandro Volta

As in not all routers pass the suffix on like my Zyxel 110 or others but your Linksys is passing this on

---------------------------------------------------------------

ajdunlop
Tuning in

I've given up and switched the Hub to router mode with our Velop network set to bridge mode. The Hub is now doing all the DHCP.