Showing results for 
Search instead for 
Did you mean: 

Hub 5 - 5Ghz not working

Dialled in


I seem to have encountered an issue with my Hub 5. It's been working great for the past six months, however today it seems the 5Ghz band has stopped working.

I've tried turning off the 2.4Ghz band to force devices to look for and use 5Ghz, however no joy. Also tried with the channels set to auto and the smart optimisation turned off, but no joy.

I'd rather not have to do a factory reset at present, I run a light show at Christmas and would be a bit of a pain having to change all the relevant IP addresses, but if needs must I can get up early one day and give it a go. Just thought i would post and ask on here beforehand.


Dialled in

After a lot of resetting, I seem to have got it working. Hopefully it will stay this way!

Hi DaveUK83, 

Thanks for your post and it's great to have you back updating the thread too. 

We're sorry to hear that there was an issue with your 5Ghz band but are glad things are resolved for you now. 

If you have any further issues, please pop back and let us know so we can offer some assistance. 

Many thanks, 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hi DaveUK83,

Has the issue resumed since you have done the reset? I also have the Hub5 that had no issues since being installed. On Monday, my iPhone was disconnected in the morning and doing exactly the same issue you are facing. I have split the SSID's, LAN works fine and so does 2.4Ghz. I have done 60 second reset, setup the router settings to my preference and the next morning same thing. I have phoned Cust Services they said they will "monitor" but at the moment I cannot use 5Ghz has iPhones and iPad are refusing to connect so I have connected all devices to 2.4Ghz and so far been fine. I have changed security settings including disabling Channel Optimisation but hasn't helped. Something on the 5Ghz band is causing an issue, ironically this has only happened this week on Monday onwards. Turning router off for 30 minutes and turning back on doesn't make a difference either.

On our wavelength

I’ve had the same issue. When I first got the hub5 I noticed that my computer would only connect to the 2g part of the SSID, so I split the names (added ‘-5G’ to the 5G’s name) so I could tell what I was connected to when things got slow. It worked fine for a few months but last month the 5G band just wouldnt be found on the computer BUT would show fine on the iPhone. I tried lots of things to solve but the only thing that worked was to reset (not restart) the router. 
It worked normally up until this week when the same thing happened, but this time the iPhone couldn’t see the 5G either. Did another reset yesterday and it’s back to temporary normality. Don’t expect it to last though.
Connecting to the router on the computer via Safari and running the diagnostics shows there are errors with WiFi and Ethernet but no further info. 
I also noticed that the Virgin Connect app (iOS) is now unable to find the hub - that I’m connected to over WiFi 🫣

…well that didn’t last long. 5G once again invisible to computer. This isn’t a signal strength issue. When it works the signal is strong. 
Is this only affecting people who split the SSIDs?

Thank you for popping back to us @garyboozy and we are so sorry to hear that this fix didn't last


Can I ask if you have connection issues when the frequencies are not split at all? 



Hi, as i said earlier, my computer would only connect to the 2g part of the SSID so I had to split them to make sure of the 5g connection. I'd just disable the 2g but that would stop my 'smart plugs' working so not really an option.

Forum Team (Retired)
Forum Team (Retired)

Have you tried a full factory reset of the hub? 


I am not saying that it will fix it and everything will work - but it's definitely a suggestion we would ask you to try. 




Well an update to mine. I left it for a week after calling Virgin Cust Services, I also noticed my Hub 5 had updated to the new Firmware. Could only connect via LAN or 2.4Ghz. Yesterday done a pin hole reset for 60s. Setup the router again to my preference, SSID names, password, also DHCP filtering, so far everything is working how it should on both 2.4 & 5Ghz and devices are connecting and showing full broadband speed upon running a Speed Test. Lets hope its stays like that for the foreseeable future!

One thing I'd love to know is why the Hub 5 has such a mess in DHCP assignment? It gives out IP's (.57, .125 etc) in random range, rather than starting at .10 which is what the DHCP setup shows as starting range and going upwards. I have inputted the MAC addresses for all my devices and told the router which IP to assign all the time  to each device so they keep the same IP, Just something I prefer my devices to have.