Showing results for 
Search instead for 
Did you mean: 

HUB 4 Issues

Joining in

Before I mention the HUB 4 I wish to mention the HUB 3

The HUB 3 was absolutely perfect, could even walk down the road and still be connected, was never any problems. Then one day Virgin decides I need to upgrade to the HUB 4. 

What an absolute nightmare ever since day one.

1/ The HUB 4 has an intermittent in and out issue that has never been resolved, even with a visit of an engineer many months ago.

2/ The range is terrible, have had to have 2 Virgin Pod extenders and still have issues. 

3/ After configuring 5Ghtz and applying changes all seems well. But soon after the HUB 4 defaults it's own preferred setting.

4/ My devices using the WiFi now state Weak Security. They say I should configure the HUB 4 to use WPA2 (AES) or WPA3 security type. The HUB 4 I have installed doesn't have those options at all.

Multiple phone calls and stress over many months or even years now since I had the Hub 4 installed. Most of the Indians who you contact have absolutely no idea and don't listen properly to explanations. That's assuming you can understand a word of what they're saying.

After one recent conversation the Indian lady has organised a new HUB 4 to be sent out. I asked her if I would be able to configure WPA2 (AES) or WPA3 security type. She assured me it definitely would although I have some serious doubts.

I really want to go back to the Hub 3 so was wondering if this was possible?


Very Insightful Person
Very Insightful Person

What speed tier are you on?  The Hub 3 only does up to 600 AFAIK. There is no WPA3 on the Hub 3 or 4, but should be WPA2 Personal?  Have you tried a full 60 second pinhole reset on the Hub and tried it with the "out of the box" settings, i.e. don't change anything?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Very Insightful Person
Very Insightful Person

Also as you have pods you must use the combined SSID and intelligent WiFi otherwise they will not work. 

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

Alessandro Volta

Hubs with modem mode option all work fine get yourself a better router like this

ASUS RT-AC65P Dual Band AC1750 Gigabit Triple VLAN, MU-MIMO, USB 3.1, QoS, Access Point/Repeater/Bri...


Forum Team
Forum Team

Hi AJHammer

Thank you for your post and welcome to our community.

We're so sorry to hear about the issues you're having with the hub 4.

We can see the community have provided some helpful responses to help resolve this.

Have any of these suggestions worked for you?

Please pop back to us when you can. 



Vikki - Forum Team

New around here? To find out more about the Community check out our Getting Started guide