cancel
Showing results for 
Search instead for 
Did you mean: 

HDMI Connected to External Monitor to My Laptop Causes Internet to Disconnect.

Timmybob
On our wavelength

Hello. I need help with radio wifi signals, please.

Thank you.

 

What is the problem?

I have discovered the cause of my internet dropping.

Whenever I’m connected via my HDMI that links my laptop to my external monitor, my internet drops. When I disconnect the HDMI cable, the internet is restored.

Numerous people have had this issue on the internet and their solution is to do with changing the channels/bands for the Wi-Fi signals as there is a conflicting interference between the external monitor HDMI and the HDMI connection to the laptop.

 

What have I tried so far?

  1. Factory reset Virgin Media Hub 3.
  2. Reset Network adaptors.
  3. Check Network adaptors drivers are up to date.
  4. Installed latest graphics card.
  5. Installed latest Windows update.
  6. Turned off my Virgin Media Hub 3 and turned it back on.
  7. Checked the wires and cables are all in correctly.
  8. Wifi works laptop without the HDMI plugged in
  9. Wifi works on my phone and other computers without the HDMI plugged in
  10. Tried another type of HDMI cable

 

What do I need help with?

I’m confused about where and what I need to do with the Wi-Fi signals to allow my Wi-Fi to work again with my HDMI external monitor connected.

 

Here are my current factory restored specifications/properties for my Network Adaptor

Timmybob_4-1717420241248.pngTimmybob_5-1717420248113.pngTimmybob_6-1717420264207.png

Timmybob_7-1717420276288.png

Timmybob_8-1717420285183.png

Here are my current advanced settings for my wireless signals on Virgin Media wireless hub 3

Timmybob_9-1717420356576.png

 

Thank you.

 

13 REPLIES 13

Sephiroth
Alessandro Volta

Seems to me that you might have a low quality HDMI cable, possibly unshielded that is emitting RF noise.  Please try with a different cable.  This is a known challenge.

Seph - ( DEFROCKED - My advice is at your risk)

Timmybob
On our wavelength

The 'preferred band' setting does not turn off the 2.4GHz wi-fi on the laptop. It tells the device to prefer (and to use) the 5GHz signal when both 2.4GHz and 5GHz are available so the 2.4GHz setting will still be available on the adapter settings.

What I meant was unfortunately disabling the 2.4GHz on the hub caused the Wi-Fi to go down and the extender to try and to go through the installation process again. It looks like the extender is using 2.4GHz as when I did a pin reset on the hub itself it reappeared eventually.

When you disable the 2.4GHz signal on the hub the wi-fi will go off (for some 2.4GHz-only devices), that's the idea. You are aiming to test your laptop using 5GHz only and see if the HDMI issue persists when only 5GHz is in use. Forget about the extender for the moment. Turn it off for testing purposes.

Turn off the 2.4HGz wifi and the extender. Check you have a good 5GHz signal at your laptop before testing the screen. If not, test with your laptop/screen near to the hub (so you don't have signal strength problems) using the 5GHz connection. See if the HDMI screen issue still happens once 2.4GHz is taken out of the equation.

I did turn it off the 2.4Ghz on the hub and it caused a lot of problems, unfortunately. The problem was still persisting if I can recall correctly with the non extender.

Your laptop model seems to be dual band capable and wireless AX capable so it should connect to the 5GHz signal without a problem.

If the problem persists with 5GHz, flip the test process around and turn off 5GHz and test using 2.4GHz only. See if you have a problem using 2.4GHz only.

If one of the frequency bands works, and is unaffected by the screen issue, use that frequency for your connection. If both are affected then you will have to start looking at other things to try.

Thank you for the other tips. 

 

Hey, thank you for the reply. But I've already tried this.

What have I tried so far?

  1. Factory reset Virgin Media Hub 3.
  2. Reset Network adaptors.
  3. Check Network adaptors drivers are up to date.
  4. Installed latest graphics card.
  5. Installed latest Windows update.
  6. Turned off my Virgin Media Hub 3 and turned it back on.
  7. Checked the wires and cables are all in correctly.
  8. Wifi works laptop without the HDMI plugged in
  9. Wifi works on my phone and other computers without the HDMI plugged in
  10. Tried another type of HDMI cable

Timmybob
On our wavelength

Fixed.

The original problem was disabling the 2.4Ghz about a week ago but despite re-enabling it, the problem persisted. 

Spent the day [04-06-2024] disabling channel optimisation. Enabling it. Disabling it. Enabling it etc. turning off the switch of the hub itself.

Looked at the connected devices channel list on the Wi-Fi analyser app on my phone and for 2.4GHz. Then on the Hub Site 192.168.0.1 only choosing the best channel with channel optimisation disabled. Then Enabling it. Disabling it. Enabling it etc. Letting it time out.

Possible problem was despite the channel optimisation being on there was maybe still a problem with it choosing the channel…it wasn’t actually choosing the most optimal one. Turning it on/off etc maybe has helped.

Also I removed the Bluetooth razer stuff last night from my PC, removed the USB razer and have returned the mouse.

Also Razer Cortex is not the active power plan anymore.

Thank you to everyone who shared their thoughts, tips and advice.

 

My current settings on the Hub/other settings following the fix:

Timmybob_1-1717605639990.jpeg