cancel
Showing results for 
Search instead for 
Did you mean: 

Can't send emails unless I'm on home network

qwertyuiop2
Tuning in

I can send emails from my iphone (blueyonder.co.uk email address) as long as I'm using my home wifi.

However, as soon as I leave the house, I get an SMTP server authentication problem (password incorrect error), using 4G/5G or other wifi.

Since I'm not changing my SMTP credentials on my iphone, it must be a problem with Virgin's authentication mechanisms when the connection is from outside the Virgin network. It's not a DNS issue, because I can resolve and ping smtp.blueyonder.co.uk successfully when out and about.

Any idea how this can be fixed?

1 ACCEPTED SOLUTION

Accepted Solutions

coenoby
Very Insightful Person
Very Insightful Person

@qwertyuiop2 wrote:

I can send emails from my iphone (blueyonder.co.uk email address) as long as I'm using my home wifi.

However, as soon as I leave the house, I get an SMTP server authentication problem (password incorrect error), using 4G/5G or other wifi.


My first thought would be that you are using out of date settings in your iPhone that do not include your full sender authentication. I am wondering that the Username field in your current settings is just the first part of your Blueyonder email address rather than the full Blueyonder address,

If that is the case, when sending from you VM home network VM also use your IP address to validate your sent emails so you can send successfully. Without your full Blueyonder address as the Username when sending from other networks you will get an authentication error.

Here are the recommended VM email settings. They are the same for all VM's email domains, just make sure that the Username is your full Blueyonder address rather than just the part before the @ symbol,

Incoming
Account type IMAP
Username richard.branson@virginmedia.com

Server port 993
Authentication Password
SSL/TLS Yes
Server host imap.virginmedia.com

or:
Account type POP3
Username richard.branson@virginmedia.com

Server port 995
Authentication Password
SSL/TLS Yes
Server host pop3.virginmedia.com

Outgoing
Account type SMTP
Username richard.branson@virginmedia.com

Server port 465
Authentication Password
SSL/TLS Yes
Server host smtp.virginmedia.com

Bear in mind that sometimes iPhone mail apps don't seem to like being updated so you may have to delete the Blueyonder account from you iPhone and then add it back as a new one.

Coenoby

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media.

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

See where this Helpful Answer was posted

12 REPLIES 12

qwertyuiop2
Tuning in

I have a similar error - I can send emails from my iphone as long as I'm in my house, using wifi on Virgin media internet connection.

However, as soon as I take my iphone away from my home and try to send email while on a 4G / 5G network or other wifi network, I get a password error and the email is never sent.

Miraculously, as soon as I go home again, the email is automatically sent.

Now I haven't made any changes to my iphone email settings, so the problem is obviously within Virgin's network and SMTP servers are not correctly responding to SMTP authentication unless the supplicant is within their network. That really is useless for people who need to use email when away from home, and can't use the webmail client on a small iphone.

coenoby
Very Insightful Person
Very Insightful Person

@qwertyuiop2 wrote:

I can send emails from my iphone (blueyonder.co.uk email address) as long as I'm using my home wifi.

However, as soon as I leave the house, I get an SMTP server authentication problem (password incorrect error), using 4G/5G or other wifi.


My first thought would be that you are using out of date settings in your iPhone that do not include your full sender authentication. I am wondering that the Username field in your current settings is just the first part of your Blueyonder email address rather than the full Blueyonder address,

If that is the case, when sending from you VM home network VM also use your IP address to validate your sent emails so you can send successfully. Without your full Blueyonder address as the Username when sending from other networks you will get an authentication error.

Here are the recommended VM email settings. They are the same for all VM's email domains, just make sure that the Username is your full Blueyonder address rather than just the part before the @ symbol,

Incoming
Account type IMAP
Username richard.branson@virginmedia.com

Server port 993
Authentication Password
SSL/TLS Yes
Server host imap.virginmedia.com

or:
Account type POP3
Username richard.branson@virginmedia.com

Server port 995
Authentication Password
SSL/TLS Yes
Server host pop3.virginmedia.com

Outgoing
Account type SMTP
Username richard.branson@virginmedia.com

Server port 465
Authentication Password
SSL/TLS Yes
Server host smtp.virginmedia.com

Bear in mind that sometimes iPhone mail apps don't seem to like being updated so you may have to delete the Blueyonder account from you iPhone and then add it back as a new one.

Coenoby

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media.

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

用心棒
Very Insightful Person
Very Insightful Person

@qwertyuiop2 wrote:

I can send emails from my iphone (blueyonder.co.uk email address) as long as I'm using my home wifi.

However, as soon as I leave the house, I get an SMTP server authentication problem (password incorrect error), using 4G/5G or other wifi.

Since I'm not changing my SMTP credentials on my iphone, it must be a problem with Virgin's authentication mechanisms when the connection is from outside the Virgin network. It's not a DNS issue, because I can resolve and ping smtp.blueyonder.co.uk successfully when out and about.

Any idea how this can be fixed?


It would be helpful to see what error code is returned by the SMTP server in this situation. From a desktop or laptop device open a Command Prompt in Window or otherwise a Terminal. and enter the following where username:password is replaced with your email address and password, i.e. richard.branson@virginmedia.com:rotavator-racecar-tenet-repaper:

curl -v smtps://smtp.virginmedia.com -u username:password

Do not post the resulting output here but instead review it for possible reported causes, i.e. VM error code; choosing to ignore this advice and posting the unredacted or incorrectly redacted output here will likely reveal your email address, password and / or public IP Address.

FYI if there is no issue then you should see the following output from the curl command:


> AUTH PLAIN
< 334
> [Redacted]
< 235 2.7.0 SMTP350 Authentication successful for user [Redacted]
> HELP
< 214-2.0.0 This is cmsmtp ESMTP service help
214-2.0.0 This is cmsmtp ESMTP service help
< 214-2.0.0 To contact postmaster send email to postmaster@virginmedia.com.
214-2.0.0 To contact postmaster send email to postmaster@virginmedia.com.
< 214-2.0.0 For local information send email to Postmaster at your site.
214-2.0.0 For local information send email to Postmaster at your site.
< 214 2.0.0 end of HELP info
214 2.0.0 end of HELP info
* Connection #0 to host smtp.virginmedia.com left intact

Otherwise an unsuccessful result will look similar to the following:


> AUTH PLAIN
< 334
> [Redacted]
< 525 5.7.13 Authentication Denied (VM320)
* Closing connection 0
* TLSv1.2 (OUT), TLS alert, close notify (256):
curl: (67) Login denied

-- 
I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more
Have I helped? Select Mark as Helpful Answer or 🖒 Kudos to say thanks

Thanks - I have 2 email accounts on my iphone, both blueyonder. My primary account is set up just as you specify, with the full username / email address and smtp.virginmedia.com.Even so, I was unable to send emails outside the VM network - and I couldn't understand why the incorrect password error was associated with "smtp.blueyonder.co.uk".

However, the secondary account still had smtp.blueyonder.co.uk and BOTH accounts were throwing wobblies when attempting to send - this was really strange because the smtp.blueyonder.co.uk secondary was "OFF" in the mail settings for the primary account.

As I didn't want to delete the primary account from the phone, which would have removed all messages, I tried deleting the secondary account only, as it only has a handful of messages. After recreating the secondary email account with the correct settings (smtp.virginmedia.com), both accounts can now send email while outside the VM network.

I guess that is an iphone peculiarity.

Thanks for this, at first I thought it would not be applicable to an iphone, but I googled "Curl + iphone" and found icurlhttp on the app store that looked like it might do the job, so I downloaded and installed it (it's free).

It's not possible to use the same curl syntax you have provided, but you can add username and password as options in Settings, which does the same as "username:password". Then select "iphone" from the browser list and run a POST to smtps://smtp.virginmedia.com.

The result I got (after resolving the problem, see previous post) is as follows:

220-csmtp2-prd-nl1-vmo.edge.unified.services csmtp2-prd-nl1-vmo.edge.unified.services ESMTP server ready
250-csmtp2-prd-nl1-vmo.edge.unified.services hello [], pleased to meet you
250-HELP
250-AUTH LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250 OK
334 
235 2.7.0 SMTP350 Authentication successful for user XXXXX.XXXX@blueyonder.co.uk ;
214-2.0.0 This is csmtp2-prd-nl1-vmo.edge.unified.services ESMTP service help
214-2.0.0 To contact postmaster send email to postmaster@virginmedia.com.
214-2.0.0 For local information send email to Postmaster at your site.
214 2.0.0 end of HELP info
221 2.0.0 csmtp2-prd-nl1-vmo.edge.unified.services csmtp2-prd-nl1-vmo.edge.unified.services closing connection

 I hope that may be useful for someone else.

 

 

[MOD EDIT: Subject title changed for clarity]

ravenstar68
Very Insightful Person
Very Insightful Person

I'm going to answer this in stages, and I'm going to be blunt.

I guess that is an iphone peculiarity.

I guess you just learn to dig into the settings a bit better - SMTP is SMTP - some servers have quirks due to the security settings on the account, but if you are using the correct settings it should work both at home and away from home.

Oh and before you criticise me - I used to be a Virgin Media customer and have a blueyonder.co.uk email address set up on different devices - including multiple iPhones and iPads across changing iOS versions.

With regard to the suggestion of deleting the account and setting it up again.  That's not necessary.  You can edit the account settings in situ provided you don't change the incoming account type.

  1. Go into Settings->Mail->Accounts
  2. Tap the name of the Account that's giving you trouble.
  3. Tap Account settings
  4. Under Outgoing Mail Server tap SMTP
  5. Make sure there are no Other SMTP servers showing
  6. Tap Primary
  7. Ensure the settings are shown as below
    ravenstar68_0-1717125617367.png
  8. Note: The password field MUST be populated and should be the same password as is used on the incoming side and the Authentication type is Password.

    The email address MUST be your full blueyonder email address - i.e. joebloggs@blueyonder.co.uk
  9. Tap done when you've changed these settings and the phone will try verifying them.  If they are good they will all be ticked and you can tap Done again.

If this fails then I'd recommend visiting whatismyipaddress.com when on the mobile network to get your IPv4 address and checking to see if the IP is listed on Spamhaus's block lists - ignore any listing on the PBL though - that's normal.  HOWEVER being as your other account can send whilst being away from home - I think that providing the settings are correct this won't be necessary..

 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

coenoby
Very Insightful Person
Very Insightful Person

@qwertyuiop2 wrote:

I didn't want to delete the primary account from the phone, which would have removed all messages,


It's obviously better if you can resolve the problem without deleting the account.

However whether you will lose all you emails if you delete the account from your iPhone depends on which protocol you are using in the email account settings on your app.. Basically it's whether your Incoming server is set to imap.virginmedia.com or pop3.virginmedia.com.

Putting it simply,

  • :with IMAP you should not lose any emails, they will reappear when once you have successfully added the account back.
  • With POP3 you definitely lose any emails you have sent using the app and you cannot get them back.

Here's the explanation for that:

IMAP is the more common one these days and email apps usually push you towards using it. It syncs all your email folders with the VM  server.

All you emails, incoming and outgoing, are actually still stored on the VM server. Your emails are only deleted from the server when you delete them in the app.

So if you delete the IMAP account from the iPhone and then add it back again the IMAP protocol will re-synchronise with your email account on the VM server. As a result all your emails and folder structure will reappear on the iPhone as they were before.

POP3 is an older protocol that was originally designed to be used on just one computer. It simply downloads new incoming emails from your account on VM server. As a result it means that any messages you send using your app are only stored by the app. So deleting a pop3 account from an email app does indeed mean that you will lose all your sent messages.

I hope that clarifies things a bit.

Coenoby

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media.

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

ravenstar68
Very Insightful Person
Very Insightful Person

@coenoby  To be frank, they really shouldn’t need to delete their account.  I’d delete and re enter the password and possibly check the username etc.  In the old days Apple didn’t delete the SMTP server details when you deleted the account.  I did create a post about it.  I think it’s been changed in the later iOS versions though.  I just don’t believe in removing everything if we can avoid it.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Indeed, deleting an account really should be the very last, I have nothing to lose now option - because if it doesn’t work, then the user has now probably lost all of their locally stored email. I always wince slightly when I see this suggested by forum team members as a ‘first thing to try’.

The OP says that they deleted the 'secondary account' and set it up again and afterwards both it and the ‘primary account’ worked. I suspect that when they re-set up the account, it overwrote the default SMTP authentication details which were inherited by the primary account.