Showing results for 
Search instead for 
Did you mean: 

TV Go app not working on iPad

Joining in

Hi, I’ve just joined Virgin and I’m unable to log into the Virgin TV Go app on my iPad - iPad is up to date re: software. The app is working on my iPhone but just keeps saying service is unavailable please try later. 
Any help would be greatly appreciated. 


Forum Team
Forum Team

Hey @Pete111,

Welcome to the Community Forums and thanks for the post.

Sorry to hear you have been having this issue, can you confirm via image what shows on the iPad when you are using this? Can you also confirm what iPad you have as well as what IoS it is running?


Hi Joe,

Many thanks for responding. I tried downloading the app directly from Apple Store to no avail. I rebooted my iPad and tried again - no avail.

I then went into my Virgin account and downloaded the app via the link to the Apple Store - rebooted my iPad and it worked. All up and running now, but thanks again for responding.

Best wishes,


Glad to hear this has been resolved Pete 🙂

Thanks for letting us know.