cancel
Showing results for 
Search instead for 
Did you mean: 

Web safe not working any more

Nothappy1234
Settling in

Frustrated, searched for help with this everywhere , it was working perfectly and now it’s not blocking any websites , Called customer service no help whatsoever , I really feel like switching providers as this is a safety issue.

can anyone help with getting this to work?

4 REPLIES 4

legacy1
Alessandro Volta

just use 1.1.1.3 and 1.0.0.3 on the devices for DNS

---------------------------------------------------------------

Client62
Legend

Take a close look at the device, is it using a Public DNS ( may look like: dns.google or 8.8.8.8 )
or is it an iOS 17.x device with Apple Relay enabled - either will bypass Web Safe.

Charlotte5678
Tuning in

I have had this issue for a year so many phone calls googled the hell out of it. Customer service have no clue and take you round in circles suggesting its your devices. If the issue is on every device the problem is with virgin media.

Factory resting the router worked a couple of times. Ringing sometimes temporarily solved the issue but not for long. Probably as you can see from other posts the only other suggestions are changing dnd settings on every device, or buying another router and putting vm one into modem mode. 

All of which you shouldn't have to do as you are paying for a service that does not work and is a security risk, not family safe and certainly doesn't keep children safe online as virgin advertise 

My advice would be to write formal complaint through their online form, report them to ofcom and just switch providers to save yourself a massive headache 

Ashleigh_C
Forum Team
Forum Team

Hi there @Nothappy1234 

Thank you so much for your post and welcome back to the community forums. 

I am so sorry to hear that you are facing this issue with your service, I would be happy to take a closer look into this with you via a private message. I will pop you a PM across now, please keep an eye out for the envelope at the top of your screen alerting you to a new message.