cancel
Showing results for 
Search instead for 
Did you mean: 

WiFi Calling Not Working

YodaP
Joining in

I have a Galaxy S22 with SIM only contract, I have enabled WiFi Calling on my phone in settings but it does not work.  Any ideas how to fix?

1 ACCEPTED SOLUTION

Accepted Solutions

Client62
Hero

On our Samsung phones there are 2 controls for WiFi Calling.

1) Settings >>> Connection >>> Wi-Fi calling    Enabled.

2) From the Phone icon >>> 3 horizontal dots >>> Settings >>> Wi-Fi Calling >>> Calling Preference  >>> Select Wi-Fi Preferred

"Mobile network preferred" was the default & this prevent Wi-Fi calling when a GSM signal is available.

See where this Helpful Answer was posted

6 REPLIES 6

Client62
Hero

On our Samsung phones there are 2 controls for WiFi Calling.

1) Settings >>> Connection >>> Wi-Fi calling    Enabled.

2) From the Phone icon >>> 3 horizontal dots >>> Settings >>> Wi-Fi Calling >>> Calling Preference  >>> Select Wi-Fi Preferred

"Mobile network preferred" was the default & this prevent Wi-Fi calling when a GSM signal is available.

Unfortunately my S22 settings are already correctly set.  WiFi enabled and also WiFi set as preferred over Mobile network.  However, thanks for the info, it was good to check and confirm.


In the Virgin Media online account - make sure "Child Safe" is Disabled.   

I have contacted Virgin Mobile, calling via WiFi is off as default and I needed to make a request to enable this.  Thank you for your help!

Hi there. I have the same problem and have spent hours and hours on the phone to VM. Do you know which team you spoke to and what they did to fix it? 

Hi Ali-R

Thanks for your post, sorry to hear you have the same issue with WiFi Calling.

All Virgin Mobile customers have now migrated over to O2, meaning that you will now need to speak with O2 directly in order to get WiFi Calling enabled. 

You can find all the contact information for O2 here.

Please let us know if you need any further help or advice from there 😊

Beth