Showing results for 
Search instead for 
Did you mean: 

Wi Fi not working.

On our wavelength

Hi there support.  I had a power cut this evening and my router reset.  However, since then, the Ethernet has been fine, but the WiFi now fails to authenticate my phone.  I have subsequently tried to reset the router, but that has failed to solve the problem.  I am using a Superhub 3.  Please help, as this has me quite perplexed.  Thanks.


Alessandro Volta

another wifi fail on the hubs wifi you need a new hub



Via a Ethernet connection login to the Hub admin menu and
check the Wireless SSID and Passwords are as expected.

On our wavelength

I did a login and can confirm that everything is still the same.  So the WiFi part of the router appears to have malfunctioned.


Try pressing RESET for 60 Seconds, then leave the Hub 3 powered on to perform a factory reset.
(The Hub will revert to using the Passwords from the bottom side sticker)
If this does not revive the Wi-Fi, request a replacement Hub.

Alessandro Volta

The key thing we'd need to know is whether or not your Hub's SSIDs are advertised to your phone.  If so, precisely what happens when you try to connect (and have you turned your phone off/on)?

If the SSIDs are not advertised and if the Hub's settings are correct, Legacy's advice stands.  The Hub 3 is an awful device for a whole load of reasons, particularly its flawed Intel chip which causes it to go into a tizz-wozz every so often.


Seph - ( DEFROCKED - My advice is at your risk)

Hi @oomph_demon,

Thank you for your posts and welcome back to our community forums. We're here to help.

I'm very sorry to hear of your recent Wi-Fi issues. Are these ongoing today? Has the advice offered so far by the community helped at all?


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!