cancel
Showing results for 
Search instead for 
Did you mean: 

Telegram being blocked

MrJG08
On our wavelength

Bit of a weird one this, but as the title says telegram appears to be blocked on my connection.

Around 9pm last night telegram stopped updating chats and was stuck connecting on both mobile and desktop apps.

Netstat and my firewall show syn_sent but no acknowledgement and a trace from my firewall stops after the first hop on the virgin network.

I've plugged a laptop directly to the hub5x and get the same result so eliminating my firewall being the issue.

To use telegram currently I have to connect to a VPN to bypass whatever the issue is.

Posted on Reddit and someone has said they also have this issue, so are virgin blocking the telegram app (telegram site works fine) or is there a routing issue on their network.

Very odd.

40 REPLIES 40

Client62
Hero

The Virgin Media DNS blocks some Social media / Messenger / Conf call / Wi-Fi Calling applications when "Child Safe" is Enabled in the Virgin Media online account.  Perhaps see if this needs to be Disabled & retry.

"Child Safe" is a DNS content filter, so it is easy to bypass by modifying your device to use OpenDNS or Google DNS i.e. a Public DNS that is not filtering 18+ content.

legacy1
Alessandro Volta

Unless VM are blocking then likely  routing issue

---------------------------------------------------------------

MrJG08
On our wavelength

Thanks for the reply, but there are no child safe setting enabled on my account and I run pihole on my LAN for DNS.

MrJG08
On our wavelength

Where's best to report this?

Client62
Hero

The Telegram app for Android is working for me via a VM Hub in Router mode & using the VM DNS.

rjarvis2
Joining in

Yes - getting exactly the same with Telegram. Stopped connecting yesterday evening. Connects if I switch from Broadband to connection via mobile.

Exthrick
Joining in

Same thing is happening to me

I have no child settings on 

OdeToBeFree
On our wavelength

I've been on the phone to them and have a 5.x hub, they seem to think its my router, it damn well isn't. the issue is outside of my home network but the CS agent doesn't believe that, saying that people aren't reporting it, well community forum and twitter seem to show different.

jpdyson
Tuning in

Same here. Started the evening of Friday March 1st. Spent an hour and half on the phone with their dreadful customer services on Saturday (once I'd finally managed to get through to an actual human, which seemed damned-near impossible), just to be passed from pillar to post, only to be told by some idiot who clearly doesn't know what he's talking about that it is "impossible" for Virgin to be blocking Telegram and it must be a problem with the app(!).

However, it's clearly a problem with the Virgin connection as it affects all devices connected to the Virgin connection, but on mobile data it's fine. If I connect a different router with a different internet connection (I'm a new customer so I happen to have my old router still active) into my mesh instead of the Virgin one, then everything works fine. And if, like you, I set up a VPN to bypass blocking done by Virgin then it also works fine.

The only thing the useless customer support person did after an hour and a half was to switch child safety and web safety settings off, which I had already done and which didn't help.