Showing results for 
Search instead for 
Did you mean: 

Hub 3 not allowing Cisco AnyConnect VPN traffic

Joining in

We have recently switched to Cisco firewalls at work so now using AnyConnect client VPN. I cannot get it working for myself using my VM broadband. It just does not seem to find the firewall hostname despite being able to reach it by using Telnet on port 443. I can connect fine if I try via a mobile hotspot.

I can't find any settings relating to LLT2P/IPsec/multicast passthrough in the router settings so I'm stumped.

Has anybody experienced this issue and found a fix?




Alessandro Volta

Test with hub in modem mode


Forum Team
Forum Team

Hi there @ilazzari 

Thank you so much for your post and welcome to the community forums, it's great to have you here. 

I am so sorry that you have faced this issue with your service, to clarify, if the VPN is not active do you face any issues at all? 

On our wavelength

Firstly Anyconnect works over Virgin I use (Over SSL)

Anyconnect can use 443 (HTTPS/SSL) or L2TP/IPSEC depending on how your IT have configured

You mention testing 443 and connects through so assume you are using this

Your IT should have supplied a URL if you put this URL into a browser it will take you to the Anyconnect page, depending on the configuration if you put in your user and password it will allow you to download their AnyConnect package

If they have supplied unconfigured package (msi) then when you first launch the client an address box will appear into which you can enter the hostname they supply to you. This is a one hit thing you can reset by going into the correct directory and removing an xml file though if you have permission

Very Insightful Person
Very Insightful Person

I would also manually set the DNS on your device to Cloudflare, OpenDNS, Google etc.  This will bypass any Websafe/Childsafe filtering on the VM DNS servers that can also interfere with VPN's. 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

On our wavelength

Yes this is a good shout also if VM DNS block unclassified sites that your new VPN connection is very likely going to be this will also not work. Setting your DNS manually on the work device as per above will work around this

Hi Alessandro. I have tried this but still not working.

Hi Ashleigh. No. My service is solid. only this VPN issue.

Hi. I am the Systems Manager for our company and we have just replaced our Juniper firewall with Cisco and yes we are using SSL (after not being able to configure IPSEC due to Win11 compatibility issues!) All of the configuration is correct as I can connect to the VPN if I use my mobile hotspot. 

Hi. I am using Google DNS but this has not helped.