cancel
Showing results for 
Search instead for 
Did you mean: 

Create your Virgin Media O2 ID

mikez
On our wavelength

Hi,

I am trying to join together Virgin media and o2 logins.   

Step 1 is to change my virgin media email login and that appears to have worked.

Step 2 is to join them together and I click 

Let’s create your Virgin Media O2 ID

it takes me to this link  https://www.virginmedia.com/my-virgin-media/link-sign-in-virgin-media-o2-id

From this point I just get the whirling infinity symbol and that's it it doesn't move on. Any ideas what I should try next ?

regards

Mike

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi again @mikez 

Thank you so much for chatting with me via the PM's and I am glad to hear this issue resolved itself.

If you do have any other issues or need any assistance at all in the future please do pop back to the forums and we will do all we can to resolve this. 

See where this Helpful Answer was posted

17 REPLIES 17

Ashleigh_C
Forum Team
Forum Team

Hi there @mikez 

Thank you so much for your post and welcome to the community forums, it's great to have you back. 

I am so sorry that you have faced this issue with your service, can I just ask have you tried to access this on an alternative browser at all? 

 

mikez
On our wavelength

Hi Ashleigh

Yes I've tried it on Chrome, Firefox and my mobile so it looks like a server problem

anoyed
On our wavelength

I’m having the same problem 

Thank you @mikez and I'm so sorry to hear that you are also facing this issue @anoyed and thank you for posting. 

Can I just check, when I click this link I get given an option to sign in, are you not able to see this page at all? It just shows as loading? Or are you signing in and then seeing the infinity loading sign? 

mikez
On our wavelength

I sign in then see the page that says

Let’s create your Virgin Media O2 ID

I click Get Started and then it takes me to page described in my first post and hangs

I did step one changing email and signing in OK 

Thank you @mikez 

I'm going to pop you a private message so we can take a closer look into this and see if we can get the issue resolved. 

I will pop you a PM across now, please keep an eye out for the envelope at the top of your screen alerting you to a new message.
 

Roger_Gooner
Alessandro Volta

It failed with MS Edge but I got it working with Firefox.

--
Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection

Hi again @mikez 

Thank you so much for chatting with me via the PM's and I am glad to hear this issue resolved itself.

If you do have any other issues or need any assistance at all in the future please do pop back to the forums and we will do all we can to resolve this. 

Hi @Ashleigh_C

I'm having this exact same problem when a try to join together Virgin media and o2 logins - I've tried different servers but I still just get the whirling infinity symbol and that's it, so I'm getting nowhere.

Thanks

Jacqueline

Any ideas what I should try next?