Showing results for 
Search instead for 
Did you mean: 

Cant verify my email

Joining in

I tried to create an account with Virgin Media so I could log into the app and control some Virgin Media WiFi pods. However when I tried to create the account it failed at the verification step. Either one of two things would happen:

  • I would wait for a long time for the verification email to be sent, and once I had received it the verification link had expired. I would try to get it sent again when this happened.
  • Sometimes when I click the link in the email it loads a page that just states "Complete your profile". There isn't anything on this page for me to do or click so I can't do anything. I also can't resend the verification link.

I am now unable to:

  • access this new account
  • resend a verification link

Accepted Solutions

Thanks for getting back to us with the additional information.

What I'll do is drop you a private message so I can take your account details and have a look on our end. 📩


See where this Helpful Answer was posted


Forum Team
Forum Team

Hi spera66

Thank you for your post, welcome to the Community Forums. 

I'm sorry to hear that you're struggling to register you My Virgin Media account, that does sound frustrating. How very strange.

Have you tried loading the link from the verification email into a new browser or clearing your cache and cookies? 

Usually, you would need to enter in your date of birth and/or your security question and answer. If you haven't already provided these details and you're not being asked for them when prompted to complete your profile, there may be an issue with the page loading.

Have you tried signing into the My Virgin Media app too with any success?

Keep us posted



Hi Beth_G, thanks for the reply. Ive cleared cache/cookies and history. Ive tried the app on my mobile. Ive tried various browsers and tried via mobile, ipad, laptop and computer. Ive had virgin broadband installed on the 19/02/24 this week. ive had my email verified for access to this forum, but not on my virginmedia account. In all cases above this is what happens when i try to verify my account : I click on to register, it sends me an email, sometimes it comes through to my inbox to verify, sometimes i have to ask it to resend verification email as i havent received it, sometimes it takes along time to enter my inbox, sometimes i dont receive anything. When i click on the verification link it opens for 1 second a box to enter my email but then before you can enter any part of your email, it jumps to ''complete your profile'' and this immediately changes to ''verification link'' expired. Its been like this since yesterday (its never displayed any questions, or boxes so far), Thank you.

Thanks for getting back to us with the additional information.

What I'll do is drop you a private message so I can take your account details and have a look on our end. 📩


Joining in

Exact same thing happening to me. Very frustrating! 


I have this same problem

Hi @Pdmid2024 👋 Thank you for your post and welcome to the Virgin Media Community 😀

We're sorry to hear about the problem you're having 😔

I can see my colleague has responded to you on another thread. Please reply to that at your earliest convenience.


I am having the same issue, could you help me out please?

Also I'm having issues with our actual broadband service, it keeps dropping out for periods. Was only installed Wednesday. 


Hi @d_saggers,

Thank you for your post and welcome to our community forums. We're here to help.

I'm sorry to hear you're having some trouble with your My Virgin Media Account and broadband connection too. Would you just mind expanding on the nature of both of these problems, and also what troubleshooting you've performed thus far in an effort to resolve them?



Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!

The same issue many people seem to have when attempting to verify; I either don't receive the e-mail, or when I do receive it within the 10 minutes window it says the link has expired. I have made an attempt through the live chat but they request characters from a password (not login password) I haven't yet set up so it's a dead end. 

The internet works for spells but then the router flashes red for long periods. I have tried leaving it turned off for a while, and also tried resetting. I clicked through the 'fix broadband' section and it states a flashing red light indicates a phone issue, but we don't have a phone with the service. I have made attempts to contact the technician who installed it last Wednesday but no joy. It really hasn't been a good start to our custom with Virgin media. Please help.