cancel
Showing results for 
Search instead for 
Did you mean: 

PS5 connection issue ( work with wifi, but not with Ethernet cable) HUB3

simon123321
Joining in

Just moved to Virgin

I had no problem connecting with PSN before

And I have good connections with any other device through wifi ( including PS5)

but if I connect my ps5 with ethernet cable, at first it has an error of failed to obtain IP address ( PS5 error code : CE-109503-8)

therefore I have inputted the IP address manually and it still doesn't connect to playstation network and I have no internet access at all

Can someone help

7 REPLIES 7

Client62
Legend

I am assuming that you are switching from WiFi to network cable with the PS when it is not doing any internet based tasks.

Try this page ...

https://www.playstation.com/en-gb/support/error-codes/ps5/ce-109503-8/

 

Basically I have no issue with connecting to Wifi 

tried the fix from playstation and I am able to obtain IP address now, proofing there is some block from my modem itself?

Nothing has proved it is a Hub 3 issue.

The WiFi and  Ethernet connections should both work  ( always assuming the network cable is not defective ).

Unless some port forwarding is configured on the Hub that directs data to the PS5's WiFi IP address.

Travis_M
Forum Team (Retired)
Forum Team (Retired)

Hi @simon123321 

 

Thanks for posting on our community forum and sorry to hear about your broadband issues

 

How does your connection fair via another device which uses a wired connection?

 

Regards

Travis_M
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Finn3
Joining in

I was just having this issue. PS5 connected via LAN then just stopped working. Would work on WiFi no issues. 

Logged into WiFi router using IP address and password on bottom of the router itself and found that the PS5 LAN had been put onto a MAC Address Filtering list, essentially blocking access. This is found in the Security menu on the left hand side under MAC Filtering. Not sure why or how this happened, maybe from an update on the router or something.

Deleted it from the list and works fine now.  

Adduxi
Very Insightful Person
Very Insightful Person

This is how the Connect app "pauses" devices.  It may have originated from there?  We have seen posts here where devices have been paused via the app, and the users have had to do this procedure to "unpause" them.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

I have never really used the app much, I did check it to see if anything was paused/blocked but didn't see anything.

I might have just missed it though and took the long route around it haha 👍