Showing results for 
Search instead for 
Did you mean: 

Can’t login on My Virgin Media or webmail using my email address

On our wavelength

I can’t login to my Virgin Media and consequently the webmail.  We originally had 4 aliases for the account but my email address has always been used for the primary email address so was used to login though the account is in my husband’s name.  I don’t know if this is a coincidence but a couple of weeks ago I was trying to set up my Outlook on my laptop and had to generate the new password (which I did make a note of).  As I result I had to change it on my iPhone too using the generated password. Once done the Mail app works ok but Outlook on my laptop doesn’t have an inbox.  At the time the rest worked ok but I haven’t tried to login since.  I came to login tonight and the login has changed to my husband’s email address which was originally the secondary email address and mine has vanished though my emails are still coming through to my iPhone.

Can anyone help I have no idea what has happened here.  


Forum Team
Forum Team

Hello Wendye1960-1.

Thanks for your post.

Sorry to hear about the issues you are having accessing your email account.

As the account is in your husbands name we would need to discuss this with the named account holder.

It is important that we can only discuss account details especially email access with the named account holder.

There is some help here from another post on our community for additional email access.

Hope that helps.



I’m sorry but your reply is about as much use as a chocolate teapot.  I don’t want to access his email I can already do that.  Let me get a few facts straight here.  I administer the account as my husband has no idea how to do things like that and no real interest in learning.  This is why it was originally set up on my email address as the primary.

The link you have provided is of no use to me whatsoever as I don’t have the same problem it’s not showing my email address at all only my husband’s and the original setup email address that was changed to my email address but that was the original primary.  In the scenario you have sent it shows 2 editable lines where as I only have 1 editable line.  However,  I have tried adding my email on the webmail platform this time using the password I generated for the Mail app and outlook and it worked so I will use it like that and close this.  I mainly use the webmail platform to try and get rid of any old emails I haven’t deleted.  I’m afraid I’m not good at deleting them straight away so I have several thousand old emails to get rid of 😳.

Just as a final note your response might have been more helpful if you had actually made an attempt to answer the question I was asking instead of fixating on the account being in my husband’s name.  I was asking about mine not his so that wasn’t relevant.  As it turns out I have solved the problem on my own.  Whilst I understand that because of data protection you can’t talk about his but you didn't read the question properly and if there was an ‘unhelpful response’ button I would be pressing it.