Showing results for 
Search instead for 
Did you mean: 

TV GO App Doesn’t Work

Joining in

Unable to access anything on the tv go app. Can’t watch any of my programmes I’ve recorded. Just states not connected to home network, make sure box is turned on.


ipad is up to date, box is turned on, and I am on the same network 


Forum Team
Forum Team

Hi Stargirl47 👋 welcome to community! Thank you for posting. 

Sorry to hear about this issue with watching your TV recordings via the TV GO app. 

Can we just check a few troubleshooting steps to offer further support with this? Just let us know about the following;

1) When you are trying to access the recordings via TV GO is your TV Box on?

2) If not, what standby mode is the box in? (Fast start or active start?)

3) Are you using any kind of VPN when trying to access the service? 

We will then continue to offer help! Thank you for your patience in the meantime 🌞 All the best! 


Yes it on. Also on fast start. 
No vpn? 

Thank you for that information. Can you confirm if you have been able to try the Tv Go service through the web browser instead of the app?


Website just transfers me to app. Which still isn’t working.

rang virgin media today was passed around for nearly an hour and then told i needed to connect to home network! Which I obviously already am connected.


still no further forward 

Forum Team (Retired)
Forum Team (Retired)

Hi again stargirl47, thanks for sharing more on this and sorry to see you've been unable to get this resolved over a call with our team.

We'd love to assist further, could you please check if you're able to sign in to TV Go App from a browser on this link here for us instead of going for the ''download app'' option?

Please, try and let us know if this works and if you're able to find and view any recordings there, just to be sure.

Also, please have a read at the below:

Are you using a 'Mesh' network? 

       a.) Mesh networks can run on one two modes. If the Mesh is in Bridged mode – sometimes called "Access Point" – then the box can be plugged into the Virgin Media router directly, and all will work ok. 

       b.) If it's not in Bridged mode – often called "Router" – then the box needs to be plugged into the Mesh NOT the Virgin Media router, or it will not work. 

       c.) "Router" mode is often the default for Mesh systems, so it's important to check. 

7.) Wi-Fi extenders/repeaters may also have a similar set up, so could cause a problem. Our Wi-Fi Pods should be fine though. 

Please, let us know more on the above and we're here to help where needed.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Rang them 3 times over the weekend. 1 hour calls each time. No one has any clue as to what is happening and I have had no resolution.

no I don’t have a mesh network browser directs to app 

Hi @stargirl47,

Thank you for expanding on this. Can you try deleting and then re-installing the app on your device and confirm if the problem continues for you?


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!

In the past 3 days I have done this 9 times

Hi stargirl47,

Thank you for reaching back out, have you tried using a different device, do you have a VPN connected for work?