Showing results for 
Search instead for 
Did you mean: 

Some 360 Remote Buttons not working

On our wavelength

Hi. Not a question but a quick fix for some buttons not working on my 360 remote, including Voice Search.

I tried the Virgin advice of ‘hold down TV/Rewind and TV/0 for ten seconds each’, however neither worked. So removed batteries for ten seconds, put them back in and everything now working.

So, for me it was the old ‘turn it off/turn it on again’ fix. Now going to fit new batteries.

Hope that helps.



On our wavelength

Hi. Is there a ‘Remote low battery/fit new batteries’ warning anywhere? Thanks.

Comes up on the TV screen when required, have found it does it a few times, whilst batteries are OK, so I change on third warning, unless the remote stops working.

Very Insightful Person
Very Insightful Person

I'm on my 3rd set of batteries since I got the box.

The warning came up on my screen a couple of days ago. First time I've seen it in a couple of years and I haven't changed the batteries following the warning.

The warning was unobtrusive and disappeared as soon as I pressed a button.


I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali