Showing results for 
Search instead for 
Did you mean: 

Netflix not loading

Joining in

Hi all, my Netflix is not loading on my virgin box just get a spinning red circle. I have tried turning box and router off and back on but still no luck. I can access Netflix on other devices but not on my virgin box. Any suggestions?


Alessandro Volta

If the V6 is connected to the hub by WiFi try an Ethernet cable.

Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection

Thanks but I do not have a Ethernet cable and my Disney plus YouTube etc are all working fine.

Very Insightful Person
Very Insightful Person

2 thoughts spring to mind.

1: That proves the internet connection, and leaves either an app fault or SW glitch. Have you tried accessing Netflix differently? Apps & games menu is one way, finding a programme from the guide and choosing "Watch from netflix" is another.

2: You've mentioned Disney+ but posted in the V6 board. V6 doesn't have D+ but TV360 does - are you sure you have a V6? Check here if you're not sure. Also V6 has the TiVo logo next to the video preview in the top-right, 360 doesn't.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Apologies I have a 360 box. I have tried all other ways via the box but it won’t load. It works using the menu on the smart tv but not via the tv box

I have tried with a Ethernet cable but still not working just get the spinning Circle ️ getting quite frustrating now. If I reset my box to factory settings would that help?

You could try a factory reset just select the option to keep your recordings, you will then need to sign in again to your apps.

Do you need to sign out of any of your other devices.


No need to signnn no out on any other device 

Just thinking if you were signed in to netflix already on up to 4 devices depending on which plan you have it may be stopping you signing in with virgin or are not even getting that far.

If that is the case then try the factory reset.


Factory reset did not work also when I search for something that is on Netflix it only shows me results on YouTube or BBC IPlayer for example peaky blinders. It seems it is not recognising the Netflix app on the box. Maybe need to call and get a engineer out to check it out.