Showing results for 
Search instead for 
Did you mean: 

Four weeks to fix Netflix issue…and counting

Tuning in

Hi all. 

My Netflix app won’t load. All I get on screen is the Netflix name shrinking to the N and the buffering symbol. All other apps work. I’ve rebooted Box and Router several times, checking all connections, but still no joy.

I thought VM would fix this easily, however I’m into the fourth week of being fobbed off by the Retention/Tech Teams. 

Every other Platform in my house works with the app, it’s literally just my 360 Box that doesn’t load the app.

Has anyone had this or similar issues?



Community elder

I would try a factory reset if you haven't already.

It's only a partial system reset and not a complete factory reset. You are given 2 options,

Keep Recordings
Format Disk

Choosing Keep Recordings, means you won't lose your recordings and any planned recordings or series links you've set up, but you will have to sign into your apps such as iPlayer, Prime, Netflix and ITVX again, also Match frame rate and Standby power consumption will go back to their default settings if you have changed them.


Very Insightful Person
Very Insightful Person

Hi @fithawk1 

On your 360, go to Settings > Audio & Video > Match Frame Rate  -  try setting that to Off if it's marked as On

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Thanks for helping, unfortunately it didn’t work.

Hi. Unfortunately changing match rate didn’t work.


If you have the Ultimate Volt package then you will have 2 boxes does this happen on both boxes, if you have 2 boxes and it's only happening on one box then try swapping them around to see if the problem follows the box.

If you only have one box and don't have Netflix as part of your deal are you trying to open the app to sign in with your own details. If that's the case have you tried going to your My Virgin Media account, Entertainment Services and manage your Netflix account there to see if it makes any difference, personally I think the app should open regardless and give you the option to either subscribe or login.