Showing results for 
Search instead for 
Did you mean: 

TP-Link M7200 no longer compatible with VM sim?

Up to speed

A couple of weeks ago I suddenly couldn’t use the router to access the internet with any devices connected to it, I thought it might be a problem with the sim so spoke to VM who said they would send me a new SIM card which arrived within a couple of days but didn’t solve the problem.

From here I spoke to TP-Link as it appeared it could be a problem with the device so they eventually sent me a replacement which arrived today.

This still didn’t solve the problem so I went back to VM and after a lot of testing, and swapping sims around was told it appears because VM have now switched from Vodafone to O2 unfortunately the sim is no longer compatible with the device! 

So in summary sim worked perfectly in device on Vodafone but now doesn’t after network switch to O2.

Has anyone else had a similar problem develop in the last few weeks?


Hi @cjp1,

Thanks for the update on this. I'm glad to hear you've been able to get things sorted with your SIM Card and device. I'll ensure your feedback is passed on in regards to relaying this to the team. The APN Settings is a standard diagnostic that we run when there are reported issues. As it's a 3rd-party device that initially displayed the issue, it's not something we're able to fully support in the long term.

If you need anything else, please let us know and our team and community will be happy to assist further. 


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Thanks for the reply Reece,

obviously the issue was caused initially by the transition of the VM Sim from one external network to the other.

it appears the default networks available in the TP Link M7200 APN settings don’t include one for the new configuration of the VM sim on the new network so a manual setup is required.

luckily serenity managed to get to the bottom of the issue and come up with a solution, the VM tech team in my opinion will benefit from the knowledge as this issue could be present on a number of different routers as well as the TP Link devices.

thanks for passing the info on

Hi @cjp1,

I completely understand where you're coming from with this, and agree that it is beneficial. As mentioned, the APN checks are a standard process that should be run by our teams when a customer is facing issues when using their mobile data, or connecting to the network.

Our Forums Team are already aware of this fix. However, as our call centres and technical support operate under different policies and processes, and strictly do not provide support for 3rd-party devices, it would be up to their seniority members to decide whether this is something that can be discussed.

Hope that clears things up 🙂


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Yes - that is basically what I did. Also if people stumble across this, you can do it from the web browser if you are connected to your device that way.

It took me an 90 minutes of begging for the APN settings before tech support gave in and gave them to me and it would be nice if this could be on a help page somewhere wouldn't it ?

Glad my frustration helped us both 🙂






Hi @serenity,

We already have a dedicated support page for our APN Settings. I'm sorry that this wasn't provided sooner to check things over. For future reference, or for anybody else experiencing a similar issue - this page can be found here.


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Very Insightful Person
Very Insightful Person

There is a set of APN settings in a sticky at the top of this forum page.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

These settings have worked on my MR200. Spent 2 hours with TP chat trying all methods. It was a shame they didn’t know about creating these settings. They did mention APN settings but asked me to call VM tech. They didn’t know what to do. I had literally boxed the router up but found this chat. Now working thanks, one really appreciative guy

Were you using a VM sim in the device which suddenly stopped working as mine did or was it on the first time trying to set it up that it failed?

It seems these VM SIM cards since switching external networks are not automatically compatible with a number of TP-link products, requiring some manual setting up rather than the expected plug and play.

Will the setting APN:, not become redundant when the full switch to O2 is completed? 


Will those setting still exist when everyone is migrated to O2?