Showing results for 
Search instead for 
Did you mean: 

Sound issues when roaming in EU

Tuning in

I have seen one person report he couldn't be heard when roaming in Spain.  My issue is similar, but I can not hear my caller and they cannot hear me.  If I call them all is OK.  I have two Virgin mobiles and it happens on both!  I spend a lot of time in Mallorca and really need to be able to use my phones.  Can you help please?


Forum Team
Forum Team

Hi @JillyB,

Thanks for your post, and a warm welcome to our Community Forums.

I'm sorry to hear you're having some problems with calls in Spain. To confirm, are you currently also facing issues with texts and data as well? Is this issue only in one area of Spain or multiple? Do calls work, as normal, when in the UK?

Does this also happen when trying to SIM in another device?


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Samsung S20 and an iphone both having the same problems.  Don't have any other devices to try SIM in.

Both work fine in the UK

Data, text, WhatsApp messages are all OK. But WhatsApp calls has same problem.

All OK if I make the call. 



Oh and yes same thing all over Mallorca and in Barcelona - haven't used phone anywhere else.

Hi JillyB,

Thanks for coming back with those details. To clarify things, the SamsungS20 and iPhone, are they both experiencing the same problem when using the same SIM Card?

When you have this problem on WhatsApp, are you using a Wi-Fi or 4G connection? In relation as well, do both devices have Wi-Fi Calling turned off?


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Sorry it's actually an S22.

No it's two different SIMS, two different numbers, same issues. 

Not sure but assume when calling from home it's Wi-Fi calling and when out 5G both cause same issue.

I have turned Wi-Fi calling on, on the iPhone now.  Can't work out how to do it on S22 - not a fan of Samsung! 

Thank you


Hi @JillyB,

Thanks for the information there. To turn off Wi-Fi Calling on a Samsung device, please swipe down on the notification bar at the top of your screen (this opens your Quick Settings Menu) > tap the WiFi Calling button on or off.

Or you can go to: Settings > WiFi Calling > On/Off. If you're unable to find this, you can do this from your home screen by tapping Phone > Menu > Settings > WiFi Calling > On/Off.

Please let me know if this allows you to hear incoming calls when the Wi-Fi Calling service is disabled.


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Tried to look at WiFi calling on Samsung - a search in settings brings up 17 options for WiFi but no WiFi calling!  Also tried the quick menu options but not there either.   We have tried turning WiFi off on both phones and called each other, can't hear each other.

Hi JillyB,

Are you able to take a look here 

Let me know if that helps.