Menu
Reply
mattrcole
  • 2
  • 0
  • 0
Joining in
326 Views
Message 1 of 5
Flag for a moderator

No Service in Mexico

Hi, I’ve been in Mexico for a few days and have a dual sim data plan (on Plus) so that I can use data here without roaming on my Virgin plan. I had service in Tulum on both Virgin and my data plan, and the data plan worked fine for internet. However, since leaving Tulum I haven’t had service on either. We’re now on Holbox island and the people I’m travelling with all have full bars signal and mobile data, but I get “No Service” on both Virgin and the data plan. I’m on an iPhone 13 Pro, and I’ve tried restarting the iPhone, turning airplane mode on and off, resetting network settings, updating iOS and carrier settings, and nothing’s helped. I even tried my girlfriend’s EE sim in my phone, which worked fine, while mine in hers got no service, so I think it must be something to do with my Virgin plan. I can’t call VM support as I have no service, and they don’t have a live messaging service, so I’m hoping someone here can help me instead!

0 Kudos
Reply
Natalie_L
  • 5.93K
  • 219
  • 449
Forum Team
Forum Team
306 Views
Message 2 of 5
Flag for a moderator

Re: No Service in Mexico

Hi mattrcole, 

 

Welcome to the Community and thank you for posting. 

Aside from this issue, I do hope you are enjoying your travels.

As you were able to use the service elsewhere, it does sound like roaming is set up but just to confirm, did you receive any texts from ourselves when you landed to confirm this?

Also, to clarify, when you say you are using a dual SIM for Data with Plus, is this PlusNet Mobile?

Thank you,

 

Nat
0 Kudos
Reply
mattrcole
  • 2
  • 0
  • 0
Joining in
301 Views
Message 3 of 5
Flag for a moderator

Re: No Service in Mexico

Hi Nat, thanks for getting back. I’m having a great time, yes thanks!

Yes, I got “Welcome to Mexico” texts when I landed in Cancun. I also downloaded the profile from Virginmedia.com/iosapn, the link which was sent in one of those texts.

The dual sim says “Chorro Fon” in Airalo, the esim app I bought it through, but on my phone it’s called “Plus”. Definitely not PlusNet though - it’ll be a Mexican provider.

 Thanks,

 Matt

0 Kudos
Reply
Natalie_L
  • 5.93K
  • 219
  • 449
Forum Team
Forum Team
296 Views
Message 4 of 5
Flag for a moderator

Re: No Service in Mexico

Thanks for your reply, glad to hear you are enjoying yourself.

Also, thanks for clearing up the Plus confusion, I did have to have a think about that one 🙂 

I see you have done quite a few things to fix this issue yourself so I would like to take a look from our side to ensure all the settings are correct. 

I will pop you over a private message to confirm a few details and we can go from there. The message will be available via the purple envelope on the top right of this page. 

Speak soon

 

Nat
0 Kudos
Reply
Natalie_L
  • 5.93K
  • 219
  • 449
Forum Team
Forum Team
263 Views
Message 5 of 5
Flag for a moderator
Helpful Answer

Re: No Service in Mexico

Hi mattrcole,

 

Thank you for your time and patience whilst speaking to me via private message. 

I am very happy to hear the issue has now been resolved but please do get back in touch if we can assist with anything in the future. 

Happy travels! 

 

 

 

Nat
0 Kudos
Reply