Showing results for 
Search instead for 
Did you mean: 

Virgin TV go app

Dialled in

Does anyone else have issues with the app. Almost every time I try to watch on my iPad, it gives error messages saying either you are not connected to the home network (I always am) or change setting to Local Network (that is also on). I have to keep turning it off resetting wifi and can take ages before it eventually plays a programme. If I then pause for a reason it usually stops playing and I have to start the resetting all over.

I have also tried using different browsers, Google. Firefox, edge, safari etc no difference 🤷‍♀️🤷‍♀️

I have reported it several times and it manage to get an engineer out recently but although they tried to help it isn’t something they really deal with (really…😱) they reset hub told me to stop renaming it or giving new password but still no improvement.

this is such a shame as it’s a great app when it works; I much prefer to watch stuff on my iPad while my husband watches sport etc on TV.

when are virgin going to fix this? I’ve had the same issues even when I had TiVo box, now have 360 but no changes. Surely some guru at virgin must know how to fix this permanently 🥴😡

am I alone with this problem? 

115 REPLIES 115

I am not expecting anything to happen either…. It’s ridiculous that this can’t be sorted out 

Hi @Maxwellplum 


Thanks for your response


Our team will certainly investigate this for you and we'll be sure to keep you updated if we have any updates ourself. Thanks for your patience.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Joining in

I also having the same problem logging into the virgin tv go app. It asks you to login with your virgin media login details but it does not work. There are so many people with the same problem but there does not seem to be a solution from virgin media 

hi, logging on isn’t the issue with this thread, this is re watching/recording saved content issues, due to the tv go app not detecting its on your home network, which also isn’t getting fixed anytime soon.

Hi @alecf1 Please reply to the PM my colleague sent you as we're wanting to help you with this.

Best wishes.

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

Sorry thought I had replied to last msg, what info is needed? I’m on all latest versions. Not sure what help it will be. I suspect it either needs someone to look at the code for possible changes. Ideally it would need some debug app version to get more info but suspect that’s not really possible on iOS. But as so many have the issue I’m surprised it’s not reproducible in a lab.

Dialled in

I agree, I am fed up providing the same information time after time to every person who picks this up, changing boxes, running test etc…..yet not a single thing has changed in the years since issue was first raised, 😡

Dialled in

FYI - I have attached the info below to my support ticket. Would be interesting if others experience the same.


Ok, I’ve got some more info on this issue, and the answer isn’t that’s how it’s designed.

i have 2 vm boxes. One in lounge, connected to vm hub 5 by cable, and one in bedroom connected by wifi to hub. The one in bedroom is generally turned off. Under diagnostics the one in bedroom is listed first as cpe1, and the main one in lounge listed as cpe2.

i don’t know fully how it works but suspect the vm boxes register their ip address with the mqtt broker, which I also suspect is where the tv go app is trying to get it from. I suspect this process runs on the vm boxes themselves but it seems to mainly run on the bedroom/cpe1 box. Ie the MQTT CPE status only shows ONLINE_RUNNING if the cpe1 box is on. It obviously works with cpe1 off, but it requires multiple app restarts for the cpe ip addr to finally get picked up.

with both boxes on when I check the app diagnostics the cpe 1 & 2 ip are sometimes both shown as unknown, but if I just quit the diagnostics screen and immediately go back in, no app restarts, the cpe IPs appear. Can take 2 or 3 times. It’s doesn’t require an app restart.

again this may be just all coincident but the behaviour is definitely different, and better if both boxes are on. 
Surely this mechanism should be able to cope with either box turned off. Maybe cpe1 is treated as a master box and hence this is where the mqtt broker process  is expected to run. If so it would be good to be able to alter the lounge box to be cpe1.

hope this is useful and leads to a fix.

p.s. maybe not related but with all the restarts I have been doing today I started having issues starting the app, with oops the service not available messages. First time it stopped after a while.

  • ok more info. seems my issue is related to having 2 vm tv boxes and which box is assigned cpe1. Appears this is down to the alphabetical name given to the box. I changed my 2nd box name from ‘Bedroom’ to ‘Upstairs’. Now my main ‘Lounge’ box is cpe1 and MQTT status shows RUNNING ONLINE. As above it can take a moment to get the cpe ip but doesn’t requires app restarts now. but will keep monitoring it.

Dialled in

Good luck 🤞. I only have one box and still unable to connect to tv go app 9 times out of 10 🙈