Showing results for 
Search instead for 
Did you mean: 

Virgin TV Go - can’t watch recordings

Tuning in

Hi, I was just trying to watch something I had recorded on the TV Box 360 on my iPad. I’ve already looked at similar postings and have run through the various settings etc. The TV Box is connected to the Hub 3.0 via Ethernet. All devices are on the same subnet. Private address in WiFi settings is active. I’ve rebooted the TV Box, reinstalled the TV go app, logged in again etc. but still it says “This recording is only available on your home network” etc etc

I’m running iOS/iPadOS 14.5.1, but also checked with other iOS versions
The TV Box is running build 4.31

Can anybody help?


On our wavelength

Hi Reece

ive tried all of those things. I am using a virgin wifi booster. I’ve unplugged that and still no joy. I managed to get on once last night but nothing again since. 

Hi @geogfrog,

I do apologise for these ongoing issues you're facing. Would you mind providing a screenshot of the error message that you seem to be getting, please?


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!

I’ve had the same issues for over a year; apart from them asking to reboot, check network etc there is still no real response from virgin about when the fix will  be available. Done everything they ask but nothing worked. Why offer a service that clearly doesn’t work 😡😡😡

surely some whizz kid has the answer. Can’t believe they still also haven’t added an option to receiver deleted programmes yet 🤷‍♀️🙈🙈

I thought I’d found a solution but then didn’t work either over the weekend. I’ve found if I close all other video apps it then seemed to work …. I don’t hold out much hope. 

Having same issue. Has worked after some kicking before but cant get it working now. CPE IPs also unknown. Plus now slingboxhave turned off their servers I have no other option to access my recordings. 

p.s. TOOB is coming in next few weeks with 900mb downloads/uploads so will give more options when current contracts run out..

 p.s. something i just did got it working for now! not sure which kick this time..CPE now matches the boxes ip.

Hi Alecf1, thank you for joining the thread! Sorry to hear you are also having issues watching recordings on TV Go. We just need to confirm a few details to ensure this is the same issue, so we can then offer support with it!

-Are you having issues with the picture and sound when trying to watch the recording back via TV GO? 

-Do you also have any issues when watching recordings on your TV box directly?

-Do you currently use a VPN or a mesh network?

-Is your box in Fast start or Active start mode at the moment?

Just let us know so we can help. All the best!