Showing results for 
Search instead for 
Did you mean: 

Virgin TV Go - can’t watch recordings

Tuning in

Hi, I was just trying to watch something I had recorded on the TV Box 360 on my iPad. I’ve already looked at similar postings and have run through the various settings etc. The TV Box is connected to the Hub 3.0 via Ethernet. All devices are on the same subnet. Private address in WiFi settings is active. I’ve rebooted the TV Box, reinstalled the TV go app, logged in again etc. but still it says “This recording is only available on your home network” etc etc

I’m running iOS/iPadOS 14.5.1, but also checked with other iOS versions
The TV Box is running build 4.31

Can anybody help?


Very Insightful Person
Very Insightful Person

I would assume that there is a delay to the function arriving when you swap to a new box.

As all seems to be working now, I would accept that your issue is resolved and only return here if the problem returns.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

On our wavelength

I’m also having the problem of not being able to watch recordings. It was a bit hot and miss but now it is all the time. I’ve read the thread and I have CPE IP unknown. Can you help? 


Hi geofrog, 

I'm sorry to hear you're having some issues with watching your recordings. This can sometimes happen for a few different reasons. 

The first thing to check is that your 360 box is in Fast start or Active mode instead of Eco mode. If this is already the case, make sure the app you're using and the OS of your device is fully up to date. 

Once you've done these checks, as you've mentioned in your post that the CPE IP is showing as unknown, click the icon next to the search bar in the top right corner and disconnect from your TV box and reconnect. This is a workaround that our VIP user Ernie has let us know of and it should refresh things and allow an IP to be registered. Hopefully you will then be able to watch the recordings without any issues. 


Please pop back and let us know how things go. 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Joining in

When I try to watch recorded programmes the picture pauses and is all pixelated 

everything else is fine

i think I need a new box from what I’ve read 


it’s a real pain not being able to use this function 

On our wavelength

I’m not sure why I didn’t see this back in March but I’m still having the same issue with the CPE being unknown. It only happens on my iPad. I’ve tried deleting the app and reinstalling etc. it’s been worse over the last few weeks. Most days I have to give up and use another provider. Last week it lost the signal in the middle of watching and then I couldn’t get it back 

have you got any other ideas? Thanks 


Thank you for the update @geogfrog

Sorry to hear that the issue is still ongoing. Just to confirm did you try clicking the icon next to the search bar in the top right corner and disconnecting from your TV box and reconnecting? Have you also tried rebooting your TV boxes?


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

On our wavelength

Yes I’ve clicked on the icon. It connects to the box today but it says another app is playing on the tv? Not sure what that means as nothing is playing. It won’t be connect at all despite rebooting the app several times. I’ve also rebooted my tv box. 

Thank you geofrog. 

Can you please remove the app and then if possible, clear the app data from the device? 

Then, please reinstall the app and reboot the box before trying again. 

Please let us know how you get on.




Hi Nat

I’ve done that and it’s the same issue CPE IP is still unknown. I’ve tried opening and closing the app this evening and can’t watch anything. 


Hi Jo,

Thanks for providing us with an update on this. I'm really sorry to hear you're still facing the same problem. Rather than opening and closing the app, have you fully re-installed the application itself?

In addition, can you please ensure you do not have a VPN active, or a service such as Apple's Private Relay, as this can affect the connection? Can you also confirm whether you are using a 3rd-party Router, or Mesh system and have your Hub in Modem Mode? If so, are you able to check if things work when in Router Mode?


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ