• 1
  • 0
  • 0
Joining in
Message 1 of 2
Flag for a moderator

TV GO App. "Oops, that hasn’t worked!"

Given there are plenty of posts about this, I have not come across a solution, outside of the generic "Delete the app" etc.

When I try to login to Virgin TV Go (App, browser, iPhone, iPad, Android) it says"

Oops, that hasn’t worked!

Please sign in with your main user account. Sub-accounts cannot sign in.

I have no sub accounts and this used to work at one point. I changed nothing for this to happen.

I have been trying for a long time to get this fixed, calling the support team, contacting live chat, requesting instructions but as of yet I have been unable to access the app since January and was only able to access it during the first week of my contract.

Is there someone from Virgin who can get me in touch with the relevant people so I can get this fixed as soon as possible, as this is soon to be an essential feature I need to have access to?

0 Kudos
  • 1.55K
  • 60
  • 119
Forum Team
Forum Team
Message 2 of 2
Flag for a moderator

Re: TV GO App. "Oops, that hasn’t worked!"

Hi edwardmde, 


Welcome to the Community and thank you for posting. 


I am sorry to heat you are experiencing issues when trying to use the TV Go service. 


This sounds like more of an issue with your details appearing as a secondary account.  


We can definitely help you with this 🙂 


As I am going to need to ask some account specific question I will pop you over a private message now.

This message will be available via the purple envelope on the top right of this page.


Speak soon, 

0 Kudos