Showing results for 
Search instead for 
Did you mean: 

Cannot access recordings on 360 box Android.

Tuning in

I can't access my recording on any android device. The TV go app sees the recordings, progress and can play them onto the TV but not on the phone. No mesh used, IP of box and phone in same range (192.168.1.x) app reinstalled and box rebooted. VPN deactivated and still no joy. The error message can be seen below and also the diagnostic as well. It seems the CPE IP is the issue from what I have read so far. Any ideas?




Hello pinaid0753.

I'd like to take a look into this for you.
If you don't mind, I will need to send you a private message to pass security. 
If you can check the purple envelope top right of your screen that would be great. 

Dialled in

I've just solved this issue a few minutes ago! I have a Samsung A53, Android 12. All the other questions/ answers were related to iPad/ iPhone, but I couldn't find anything for Android. On one response it talked about iPad Local Network Privacy Settings. I checked my privacy settings and couldn't find anything like this.

I solved the problem by going into Connections/ Data Usage. I checked that Mobile Data was toggled on and on the same page went into Mobile Data Usage. I scrolled down to Virgin TV Go and clicked on it. Allow Background Data Usage was toggled on, but Allow Data Usage While Data Saver is On was off. I turned it on and was able to watch my recording. The strange thing is that I have set Data Saver to off, so making that change shouldn't have made any difference. 

Hopefully this has solved your problem too. If it had then can you please mark my post as the solution. I searched extensively for an answer and couldn't find anything to help Android users. 


 Thanks for this. It hasn't worked for me but I appreciate the help. Virgin ha e not been terribly proactive!

Och that’s a shame. Was worth a try

Hi Pinaid0753,

I can see you have been speaking with my colleague over Private message who is working to resolve this for you. 

I would request you await a further update from them. 


I am waiting, still. Thank you.

Hi @pinaid0753 sincere apologies that you're still waiting for a reply.

I've given them a gentle nudge on this to see if they can push for an update for you via PM.

As soon as they are able to do so, they'll come back to you with more information!
Many thanks


Morning Tom. Had a call yesterday and was advised to use TV control. I tried to explain that this doesn't work but the agent insisted it would. I accidently got cut off from the call bit tried TV control app anyway. No compatible box found even though my 360 and phone are in the same network. The app clearly states that for Virgin 360 you need to use the TV go app (please see screenshot). I was a bit annoyed that the agent would not listen and insisted I use the TV control app. Still can't access my recordings. What is our next move?


Hi Pinadi0735, 

Thank you for your reply, I know this can be frustrating. Our team member will help further via PM.




I still have not had a message and it's now 3 weeks in. I can't see that it is this difficult to get the app to stream my recordings in my home. Could someone please get back to me with some suggestions.



1. I want to play recordings on my phone or tablet in my home.

2. My 360 box and devices are in the same range (192.168.1.xx)

3. I can see the recordings on my 360 box through my phone and tablet (both android) and play them to the TV from the phone/tablet.

4, I keep getting the message that I need to be in my home to stream recordings.

5. In the diagnostics option, the CPE ID of the 360 box is unknown which suggests this is the issue (and hence the message about having to be on my home network - which I am). N.B.: THE IP OF THE 360 BOX IS SHOWN ON MY ROUTER AND IS DEFINATELY IN THE 1I RANGE ABOVE IN 2 AS ARE MY DEVICES.


Please, please, please sort this out.