Menu
Reply
pdhurd2015
  • 26
  • 3
  • 1
On our wavelength
251 Views
Message 1 of 3
Flag for a moderator

Download speed very slow

28th Nov 2020. Upgraded from 100Mb to the new 500Mb broadband package and now I am only getting an average of 88 Mb download.....what is going on with the Liberty Global's service?

0 Kudos
Reply
Anonymous
Not applicable
222 Views
Message 2 of 3
Flag for a moderator

Re: Download speed very slow


@pdhurd2015 wrote:

28th Nov 2020. Upgraded from 100Mb to the new 500Mb broadband package and now I am only getting an average of 88 Mb download.....what is going on with the Liberty Global's service?


Wired or wireless?

For wired devices access the HUB on http://192.168.0.1 and navigate to the 'Connected devices' section. Ensure the 'Speed (Mbps)' is 1000 (1Gbps), not 100 (10/100).

0 Kudos
Reply
pdhurd2015
  • 26
  • 3
  • 1
On our wavelength
205 Views
Message 3 of 3
Flag for a moderator

Re: Download speed very slow

Hi Carl,

re: Downstream bandwidth loss on upgrade?

Answer to your question, Wired: thank you for your advice. It was set to 1000 (1Gbps). (First place I looked when bandwidth dropped)

I don't believe it is at my Router end (though I can't guarantee it's integrity further without diagnostic tools). I would hazard a guess it is more fundamental i.e. configuration not set correctly at the "Distribution Hub or in the Head-end - Management systems?"

My Router has been performing robustly, circa 95+%, without intervention for a couple of years (minimal resets)...but then suddenly dropped in Bandwidth (ave 88Mb from an ave110Mb ) directly coinciding with the upgrade  from 100Mb to 500Mb. Incidently, the upstream bandwidth has increased as per expected

0 Kudos
Reply