Showing results for 
Search instead for 
Did you mean: 

1gb but receiving 400-500

Joining in


I set my HUB5 up today and the Samknows test is showing around 1145mb in but only 4/500mb to the device.

I have this connected to my iPhone 12 via wifi.

I’ve also just plugged my ASUS router into the HUB5 and when I do a test through the ASUS router app, it is showing as 900-1000mb. Then when I connect to my ASUS wifi and do a speed test on my iPhone it shows as 4-500 again.

I’ve never had this significant a mismatch between Ethernet to wifi speed. I’ve also never had this mismatch between the ASUS app speed and that received on my devices via wifi when they’re right next to the router. I was with 3 prior to transferring to virgin and got around 650mb when next to the ASUS router.

it is almost as if it is locked to up to 500mb.

thanks in advance,



Alessandro Volta

The problem is clearly with the ASUS. Have you tried a reset?

Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection

Ah no sorry I maybe didn’t explain well. I initially had the HUB5 on its own without the ASUS router plugged in and Samknows was showing 1145 to house and 400 odd to my iPhone.

I then tried it with my ASUS router plugged in later. The router uses Ookla as its tester on the app and shows similar to what the HUB5 is showing. If I do a Samknows with the ASUS router it shows the same thing as the HUB5.

so I have the correct speed coming into the house but then when it goes through the HUB5 it drops to half the speed


You cannot test with a phone, so connect a device like a laptop wired direct to the hub and run the SamKnows check again.

Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection

I’ll remember to bring my work laptop home tomorrow to test the connection through Ethernet. That will give it 24hours to settled down as the advisor on the phone did say it can take 24hours for the connection to settle when first set up. It just concerned me the vast difference I was getting, I’d understand the odd drop outs during set up and shortly after but such a change to the speed seemed concerning.

I was using my phone as most of my devices will connect via wifi. With the 3 router I had the iPhone in the same room as the router connected to its wifi and was hitting 650mb so it just seems strange to me that Samknows is showing 1145ish in and 400ish out but will see how it looks tomorrow after work 

Thought id post the log just as there is a lot of ‘critical’ and ‘warnings’ to see if that was anything to do with it. I don’t really know an awful lot about internet, which I’m guessing shows 😅, so apologies.

Just logically to me if I’m paying extra for gig1 over M500 but getting lower wifi speeds then it’s probably worth me calling up whilst I’m in my cooling off period and saving myself some money at the same time I getting a better wireless connection 😅65D85857-2E95-4BC6-AD75-C210938707A6.png



Just grabbed my partners laptop and tested the connection via Ethernet on the 2.5gb port and a cat6 Ethernet cable and I’m getting 197-267mb via Ethernet. So it’s actually even worse over Ethernet 

Same issue here, but they seem to refuse looking into it further. How frustrating.

Open two complaints now, utter rubbish service and seems like they read off a script.

Engineer came out and admitted he has not been given the correct tools to fix issue.

Phone staff, can see the issue on their side but nothing gets done.

Wot can we do ? Taking our money and not providing the service.

Are you saying that SamKnows is showing as little as 197Mbps from a wired connection out of the hub?

Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection


Yes that is correct. It is a bit better today and goes 5-700 but that’s the same on wifi