Showing results for 
Search instead for 
Did you mean: 

Virgin media connect apps

Joining in

I used this apps for a month, but suddenly it logged out. When I logged in again, it could let me in. Just said the page was expired. Asked me to log in again, but I did it many many times. Even I uninstalled it and installed again. It is being the same problem. 


Forum Team
Forum Team

Hi @dorahsc 👋,

Welcome back to our Community Forums and thanks for your post 😊

We're sorry to hear you're having an issue with the Connect App.

The first thing to be aware of is you need to be connected to your Home Wi-Fi in order for the app to connect to the Hub. It won't allow the connection if you're on a different Wi-Fi network, Guest network on your own Wi-Fi, VPN, or mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that:

For your Apple device, if you're on iOS 15 then you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data.
If you're on iOS 16 then just delete the app from your device, restart the handset, and then re-download the Connect App. 

For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 

Pop back and keep us posted. 



Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

I tried to do what you said, but it still didn’t work with the apps. I used IOS 16 without any VPN. I cannot sign it with Connect Apps . What else I can do now?

Hi @dorahsc,

Thanks for coming back to us. Sorry that this issue is ongoing. 

Have you tried to sign into the Connect App on a different device to see if this can help? 

Can you sign into your online account without any issues?

Let us know.


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs