Menu
Reply
Ekov
  • 5
  • 0
  • 0
Tuning in
367 Views
Message 1 of 10
Flag for a moderator

Horrible customer service and unsolved problems

A week ago I ordered a broadband package as a new Virgin Media customer. For some reason during the process my Flat in the address kept being replaced with the wrong letter ( it's Flat J, the process kept handling it as Flat K). As no matter how many times i restarted the process the same thing happened, I went through with the order and asked customer service the next day to help me fix it, explaining the issue. I contacted them both via phone and via webchat several times over the next few days, every time (when they didn't hang up on me) I was told the issue was fixed and they passed on my correct address to Yodel but checking it the next day the address was still wrong on my account and delivery details. This went on for days spent hours on the phone and chat, was told it was fixed then nothing happened. The date of delivery came and Yodel couldn't find the address as it was still incorrect. I changed the address at Yodel directly and filed in a complaint about this whole mess as several employees were taking me for a fool and told me they fixed the address but they didn't. Monday I got a reply to said complaint telling me to contact pre-installations, which I tried 3 times and once nobody spoke in the phone after taking it and waiting on the hold for 20minutes (they opened the line, I could hear office background noise but nothing else....), 2 other times they straight up hang up the phone after I was connected to the team. Finally someone from another team answered my query and I was told  a new account needs to be created with the correct address so they deactivated the old one and we went through the whole registration process. Since I told them about the situation I got the equipment still on Monday, (so yesterday) and I was told I can activate my broadband on the same day. The setup didn't work, the hub shows a solid red light and whenever I was on the phone with the self install equippment team they told me different things: one said my line isn't activated yet as the order was placed yesterday (as this is a new account with the correct address...), another said I have to wait for the equippment that arrives on Wednesday (I had no idea they try to send me another self install package) 2 hang up on me and the third took my details then hang up on me. I have checked my orders for this new account and it says I have a ''click and collect'' order - when the customer service lady set up my new account she never mentioned I will get new equippment at all, and since it is not even delivery but click and collect I don't even have a clue where would they want me to go and get it. I am absolutely shocked a large company like Virgin can operate like this at all. I have equippment but I can't set it up, customer service refuses to do anything and hang up the phone, and here I am still without a broadband - I work from home and this is quite the big problem for me. 

Someone please make sense of this mess and sort it out for me as I have absolutely no idea what to do now.

0 Kudos
Reply
Z92
  • 2.59K
  • 208
  • 415
Trouble shooter
335 Views
Message 2 of 10
Flag for a moderator

Re: Horrible customer service and unsolved problems

TL;DR, can you break it up into smaller more easily digestible chunks? You still a better chance of getting a reply that way.

 

Ekov
  • 5
  • 0
  • 0
Tuning in
319 Views
Message 3 of 10
Flag for a moderator

Re: Horrible customer service and unsolved problems

Can't edit the post for some reason.

TL;DR A customer service employee re-ordered my original order and opened a new account for me as they couldn't fix an address issue. Now I have a self install kit, which doesn't work, and i'm being told different things: one is that the line isn't live yet because of the new order date, another is i have to wait until new equippment arrives. No one told me I'll get new equippment and it is set to click and collect  but no idea where it will be available either.

0 Kudos
Reply
lotharmat
  • 3.66K
  • 247
  • 677
Community elder
309 Views
Message 4 of 10
Flag for a moderator

Re: Horrible customer service and unsolved problems


@Ekov wrote:

A week ago I ordered a broadband package as a new Virgin Media customer.

For some reason during the process my Flat in the address kept being replaced with the wrong letter ( it's Flat J, the process kept handling it as Flat K). As no matter how many times i restarted the process the same thing happened, I went through with the order and asked customer service the next day to help me fix it, explaining the issue.

I contacted them both via phone and via webchat several times over the next few days, every time (when they didn't hang up on me) I was told the issue was fixed and they passed on my correct address to Yodel but checking it the next day the address was still wrong on my account and delivery details.

This went on for days spent hours on the phone and chat, was told it was fixed then nothing happened. The date of delivery came and Yodel couldn't find the address as it was still incorrect. I changed the address at Yodel directly and filed in a complaint about this whole mess as several employees were taking me for a fool and told me they fixed the address but they didn't.

Monday I got a reply to said complaint telling me to contact pre-installations, which I tried 3 times and once nobody spoke in the phone after taking it and waiting on the hold for 20minutes (they opened the line, I could hear office background noise but nothing else....), 2 other times they straight up hang up the phone after I was connected to the team.

Finally someone from another team answered my query and I was told  a new account needs to be created with the correct address so they deactivated the old one and we went through the whole registration process.

Since I told them about the situation I got the equipment still on Monday, (so yesterday) and I was told I can activate my broadband on the same day.

The setup didn't work, the hub shows a solid red light and whenever I was on the phone with the self install equippment team they told me different things: one said my line isn't activated yet as the order was placed yesterday (as this is a new account with the correct address...), another said I have to wait for the equippment that arrives on Wednesday (I had no idea they try to send me another self install package) 2 hang up on me and the third took my details then hang up on me.

I have checked my orders for this new account and it says I have a ''click and collect'' order - when the customer service lady set up my new account she never mentioned I will get new equippment at all, and since it is not even delivery but click and collect I don't even have a clue where would they want me to go and get it.

I am absolutely shocked a large company like Virgin can operate like this at all. I have equippment but I can't set it up, customer service refuses to do anything and hang up the phone, and here I am still without a broadband - I work from home and this is quite the big problem for me. 

Someone please make sense of this mess and sort it out for me as I have absolutely no idea what to do now.


There - Fixed the mess!




------------------------------------------------------------------
Hub 3 - Modem Mode - TP-Link Archer C7

0 Kudos
Reply
Ekov
  • 5
  • 0
  • 0
Tuning in
298 Views
Message 5 of 10
Flag for a moderator

Re: Horrible customer service and unsolved problems

Thanks for rubbing it in. I had to write this from mobile phone as - guess what  i don't have a broadband and my mobile data speed can't handle desktop sites. Hence, I couldn't format properly. I hope this made you feel good about yourself as I'm dealing with this for a week and I don't find it funny anymore.

0 Kudos
Reply
Z92
  • 2.59K
  • 208
  • 415
Trouble shooter
288 Views
Message 6 of 10
Flag for a moderator

Re: Horrible customer service and unsolved problems

You could have typed it out offline and then copy pasted to the online form, its what I do when handling a lot of text just in case it times out whilst trying to post it. Losing so much work would be a nightmare. 

0 Kudos
Reply
lotharmat
  • 3.66K
  • 247
  • 677
Community elder
284 Views
Message 7 of 10
Flag for a moderator
Helpful Answer

Re: Horrible customer service and unsolved problems


@Ekov wrote:

Thanks for rubbing it in. I had to write this from mobile phone as - guess what  i don't have a broadband and my mobile data speed can't handle desktop sites. Hence, I couldn't format properly. I hope this made you feel good about yourself as I'm dealing with this for a week and I don't find it funny anymore.


Woah - Wind it in a bit! - I was trying to make your message easier to read - Sometimes critical detail is lost in the paraphrase!

A method I use for typing long text on a mobile:

Use a note take app that allows 'speech --> text' (google keep will do this and syncs so you don't lose anything.)

You can format into paragraphs in that and then copy and paste. Saves a lot of hassle and time!




------------------------------------------------------------------
Hub 3 - Modem Mode - TP-Link Archer C7

0 Kudos
Reply
Ekov
  • 5
  • 0
  • 0
Tuning in
235 Views
Message 8 of 10
Flag for a moderator

Re: Horrible customer service and unsolved problems

You're right, apologies, I guess I was lashing out on the wrong people due to my frustration. Thanks for reading through it and making it more readable.

0 Kudos
Reply
Ekov
  • 5
  • 0
  • 0
Tuning in
195 Views
Message 9 of 10
Flag for a moderator

Re: Horrible customer service and unsolved problems

Just wanted to confirm that my torture has finally ended - the click and collect order was incorrect as well and I got a home delivery. With the new equipment my broadband connection is working. I'm still surprised by the amount of "incorrect" processing that happened to my order and by the attitude of customer service, but at least it is set up and running now after all of this.

0 Kudos
Reply
Laurie_C
  • 978
  • 29
  • 91
Forum Team (Retired)
Forum Team (Retired)
172 Views
Message 10 of 10
Flag for a moderator

Re: Horrible customer service and unsolved problems

Hi Ekov,

 

Thank you for getting in touch, and a very warm welcome to the Community Forum! I'm really sorry that you've had so many issues during your installation, this is hugely disappointing to hear, and I can assure you that this is far from the standard of service that we want to provide.

 

I'm glad that you've been able to get this issue resolved - if you have any more problems, please don't hesitate to get back in touch, and we will be happy to help.

 

Kind regards,
Laurie

Laurie_C
Forum Team
0 Kudos
Reply