Showing results for 
Search instead for 
Did you mean: 

WiFi issue on Google Pixel XL

Dialled in


I had a hub 3 which had issues, so I’ve now got hub 5 - my speed package is 200Mbps Fibre, newly installed.

My Google Pixel xl mobile phone, which was getting results from Failed to 0.08 Mbps upto 180 Mbps from the hub 3. As were other devices, hence the swap out to the Hub 5 as it was unusable on most devices buffering video, drop outs, not connected messages etc - iPad, Fire Stick, PC, Mobiles.

Immediately after the Hub 5 was installed my Pixel 5 is still getting either Failed speedtests, or as low as 0.03 Mbps and sometimes rarely upto 40 Mbps, even when just a few feet away from the hub. But, the other devices which were having issues with the previous hub 3 are now getting over 100Mbps consistently.

Anyone got any ideas? I like the Google Pixel and don’t want to replace it just to see what happens, it’s still as new as the day I got it and has no other issues and the high speedtest results it was getting on the Hub 3 prove it can handle high speeds over WiFi….just not at the moment on the hub 5…?






The app isn’t working correctly, so I can’t order one through it.

Can I get one through this forum? I’m on another thread on this forum asking the same question. So far I haven’t had an answer if I can or not.


Will someone please help me with this? 



I give up.

I’ve asked the same simple question many times on this forum, and still haven’t received an answer or a response that has help me in any way.

This has been a complete waste of my time.

I’m unsure as to why a forum that is set up to help people move forward and solve problems, doesn’t.


Hey Kennewby, thank you for for reaching out and I am sorry you are struggling to get onto to the connect app.

The first thing to be aware of is you need to be connected to your Home WiFi in order for the app to connect to the Hub. It won't allow the connection if you're on a Guest network, VPN or Mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that: 

For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. 

For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 

If this also fails then we currently have a known error with some of the data in our systems, that is causing the app to not recognise the Hub in a minority of instances. We are already investigating this as a high priority. 

Pop back and keep us posted. 


Matt - Forum Team

New around here?

I am connected with the app to my wifi.

everything works within the app EXCEPT speed tests - thats when I get the message telling me i ned to be connected to the hub even though I actually am.


This is the issue I'm asking for help with.

Just to be clear, again

the app works, it is connected to the hub, it is connected over my wifi, its not on a VPN or anything else - it just tells me I'm NOT connected to the hub when i try to run a speed test - this is the error in the app.

So I cannot run a speed test within the app due to this error within the app (I have the app on 2 different devices- both been re-installed many times) 

So I cannot order a max pod using the app.

I've asked on this forum if I can order one - many times - but I cannot get an answer.

What next?

Hi @Kennewby thanks for your reply, I can appreciate you frustrations with this so please accept my apologies.

Please expect a PM from me to arrive shortly so I can look to order the 2nd pod for you.

Kindly reply to my PM directly once received!
Many thanks


Thanks Tom_W




Here’s a screenshot from my IPad, it’s connected to WiFi, this is what is happening with the virgin connect app.

you can see the full WiFi bars, the WiFi on the iPad is working fine, the connect app connects to the hub, shows me all my connected devices tells me they’re all “great” connection speeds (including my Google Pixel XL even though the WiFi doesn’t work the phone? Full bars on it as well but horrendously bad experience trying to use WiFi on it (at home on WiFi, works on other peoples WiFi everywhere else without any issues). Speedtest results using, Ookla, google, SamKnows, of 0.03Mbps and sometimes FAILED test results on the phone)

on the virgin connect app I try and run a speedtest and it says I need to be connected, When I definitely am connected to the hubs WiFi , I click connect and it loops back and tells me I need to be connected. 

it’s been installed many times, on different devices, I don’t use a vpn, everything is updated. I have a hub 5. Any ideas?



Dialled in
This isn’t solved - the answer didn’t solve the problem? Why is this marked as “Solved”?