Menu
Reply
jar0996
  • 1
  • 0
  • 1
Just joined
3,238 Views
Message 21 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3

I followed the link to rectify the message and still get weak security message.  I can confirm iPhone is not faulty, I am computer literate and set up accordingly. This is an issue with the security protocols on the router and what is available to us.  Upto Virgin to catch up and update security.

BenMcr
  • 22.16K
  • 2.42K
  • 4.56K
Very Insightful Person
Very Insightful Person
3,236 Views
Message 22 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3


@jar0996 wrote:

I followed the link to rectify the message and still get weak security message.  I can confirm iPhone is not faulty, I am computer literate and set up accordingly. This is an issue with the security protocols on the router and what is available to us.  Upto Virgin to catch up and update security.


How security works on the Hub 3 has not changed and it complies with standards for both WPA and WPA 2.. The change is within iOS for the display of 'weak security' where a router uses WPA as part of the security instead of just WPA 2.

If Virgin Media force updated all Hub 3 devices to only use WPA2 this would risk breaking existing home networks for customers if they have devices that don't use WPA2 and so that won't happen.

The steps to change the setting in the Hub is the correct one to resolve the message in iOS. If it doesn't immediately do it then I'd verify that the change has completed correctly within the Hub 3 settings.

**********************************
I work for Virgin Media - but all opinions posted here are my own
0 Kudos
Reply
DaveRKeen
  • 2
  • 0
  • 0
Joining in
2,908 Views
Message 23 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3

Just connected my new Hub3 to my Apple products, all up to date software. WiFi password keeps being refused as incorrect. Unable therefore to modify Settings on my Hub. Is the weak security of significance?

 

0 Kudos
Reply
gary_dexter
  • 31.95K
  • 1.97K
  • 4.31K
Alessandro Volta
2,887 Views
Message 24 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3


@DaveRKeen wrote:

Just connected my new Hub3 to my Apple products, all up to date software. WiFi password keeps being refused as incorrect. Unable therefore to modify Settings on my Hub. Is the weak security of significance?

 


No it’s unrelated 


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
aldoug
  • 1
  • 0
  • 0
Joining in
1,871 Views
Message 25 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3

I must be thick!. I have been into the Broadband help several times and cannot change the settings from WPA to WPA2 or WPA3 on our Hub 3..

Please advise.

0 Kudos
Reply
gary_dexter
  • 31.95K
  • 1.97K
  • 4.31K
Alessandro Volta
1,864 Views
Message 26 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3


@aldoug wrote:

I must be thick!. I have been into the Broadband help several times and cannot change the settings from WPA to WPA2 or WPA3 on our Hub 3..

Please advise.


Read the instructions here: iOS 14 'Weak Security' 


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
Smit1978
  • 9
  • 0
  • 1
Tuning in
1,707 Views
Message 27 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3

Good Morning All,

I am after some help. I have had the same weak security message and I have changed the settings to WPA2. I forgot the network on my iphone and then reconnected. I no longer have the week security and the phone shows the tick to say it is connected but it still does not connect to the internet if I go on safari on my phone. I have checked on the hub's advanced settings and it is showing WPA2 only.

Any help would be greatly appreciated.

 

0 Kudos
Reply
gary_dexter
  • 31.95K
  • 1.97K
  • 4.31K
Alessandro Volta
1,696 Views
Message 28 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3


@Smit1978 wrote:

Good Morning All,

I am after some help. I have had the same weak security message and I have changed the settings to WPA2. I forgot the network on my iphone and then reconnected. I no longer have the week security and the phone shows the tick to say it is connected but it still does not connect to the internet if I go on safari on my phone. I have checked on the hub's advanced settings and it is showing WPA2 only.

Any help would be greatly appreciated.

 


Do a 60 second pinhole reset on the hub then try again 


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
paul-b
  • 36
  • 0
  • 0
Tuning in
1,398 Views
Message 29 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3

I also have this problem on my new ipad mini 5 I got this week it does not show on my ipad mini 3, I tried to change the modem settings but it would only let me change it to wpa2 and not wpa2 aes, any ideas?

0 Kudos
Reply
paul-b
  • 36
  • 0
  • 0
Tuning in
1,393 Views
Message 30 of 33
Flag for a moderator

Re: Weak security on brand new Hub 3

I did a change yesterday to my modem settings and set it on wpa2 and I don't know if I did not click apply but when I checked tonight it had gone back to the original settings so changed it again this time though it gave me wpa2-psk which did not show yesterday I clicked apply and it worked, and immediately my Echo stopped when I said Alexa play Gold I got a message "I am having trouble connecting to the internet" and I was about to pull the remaining hair on my head out and thought reset the Echo and it worked, all I have to do now is find out if it has affected anything else. 

0 Kudos
Reply