Showing results for 
Search instead for 
Did you mean: 

WI-FI Pods won’t connect

Dialled in

Hub 4 -  2 x Wi-Fi pods. The pods will not connect to the router. Customer services no help at all. Can someone please help 


Very Insightful Person
Very Insightful Person

Hi @MarcosG260492 

Have you changed anything on your hub?

The pods only work under certain conditions.

Keep your Hub in Router Mode - Do not put the Hub into Modem Mode, as this disables the Wi-Fi and your Pods are connecting to your Hub via Wi-Fi. Likewise, if you use a third-party router it will not work because the Pods are designed to specifically connect directly with VM's Hubs only.

Do not split the SSID – If the SSID is split then the hub treats the two bands as two different standalone networks (the same as picking up your neighbours Wi-Fi when you search for a network). The Smart Wi-Fi cannot move a device between different networks.

Do not disable either bands – If both bands (2.4GHz and 5Ghz) are not switched on then the software cannot move the device for optimisation, which essentially disables the Smart Wi-Fi.

You should also ensure that Chanel Optimisation is enabled in your hub settings.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

So basically - the hub has to be in factory settings.

I guess that saves on troubleshooting...

"Have you tried a factory reset?"


"Is it still not working?"


"It must be broken"

Hub 3 - Modem Mode - TP-Link Archer C7

I haven’t changed anything on my hub. I have resetted the router to factory settings. It’s seem to be an issue with VM connect app. Where it picks up the Wi-Fi pods but won’t connect them. I have even tried placing them right by the router and also wired them to the router via Ethernet to see if that helped. Can I have an engineer to come and assess please or is there an issue with the app?