Showing results for 
Search instead for 
Did you mean: 

Virgin media connect app not working

Joining in
  • I got Virgin installed this week and have weak signal in our house. I have installed the Virgin media connect act as per virgins guidance.

However, no matter what I try, on my pixel 6 phone or Chromebook, the app is unable to complete the "hub installation" to our Hub 3. 

I get wifi in half the house just fine, so the hub appears to be working, but the app does not. So far I have tried:

Rebooting my phone, Chromebook and hub Factory reseting the hub

Forgetting and reconnecting to WiFi on both devices.

The only messages that have appeared are: "Connecting Hub. Kick back while we work our magic" which can be present for over an hour, before:

"Hub not found, try again" Appears despite the devices not moving from the room that th hub is in and no indication of WiFi dropping.

Is there anyway, other than the app which does not seem to work, to be able to get the WiFi disks to allow our home to have the coverage it needs?


On our wavelength
I’m having a similar problem for a Hub 5 that I’ve had for a few weeks.
Up until a few days ago it was working, but I think there was an app update and since then it has stopped finding the Hub on both my iPad and Samsung A53 phone.

some here. only had the system install on the 02/12, tried the app same day and it worked put the app on today (3/12) and it wont connect

Forum Team
Forum Team

Hi there @allan_micthell1


Thank you so much for your post and welcome to our community forums, it's great to have you here! 


I am so sorry to hear that you are facing these issues with your connect app! 


Can I just check, have you tried uninstalling and reinstall the app as well as clearing all the cache and data within the app? 


Thanks again. 

When I run the Connect app on my ipad, although it shows that it cannot connect to my Hub 5, it shows the MAC that it is looking for. which doesn't match the MAC shown on the label of my hub.

On the android app, it just shows the type of hub, not a MAC address.

Could this be the problem?

If so, how can it be solved?


Hi markp2gill,

Please ensure you're not connected to a Guest network, VPN or Mobile Data. If you're definitely connected to just the WI-Fi, please try clearing the data within the Connect App. These steps will help you do that: 

For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. 

For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 

If these don't work, then we are currently aware of an ongoing issue with the Connect App not identifying the Hub correctly, or at all. The team who manage our Connect App are working on getting this resolved as quickly as possible. However, we do not have an estimated time for a fix at this time.

We're very sorry for any inconvenience caused.


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

I have tried all the above and still not able to connect to the Hub 5, I have black spots in my house so need some WifiPods, so I need this issue resolved so I can can get some ordered

Hey @DP31,

Thanks for getting back to us, upon checking the system I can see your router is currently operating in Modem mode, whilst it is in this the app won't pick up the Hub as you are not using the signals produced by it. We would ask you to turn this off and then run the tests via the app as this will register any black spots you may have.

Thanks. Joe