Showing results for 
Search instead for 
Did you mean: 

Virgin Media Connect app will not connect to Hub 5

Joining in

Hub is set up and installed but trying to connect via the Virgin Media Connect app and it fails instantly after clicking through install process.


Error message reads "We can't find your Hub. Looks like we've lost connection. Please try installing again" and the cycle continues.


Any help please?



VM Connect App

For the VM Connect app to work the phone needs to be connected to a Router mode Hub via WiFi and VPNs must be disabled ( i.e. all forms of Apple’s Private Browsing tools / NordVPN and the like must be off )

If you have reinstalled the VM Connect app and it still does not find the Hub the VM back end systems are often the cause,  just try again in a few days.

Don’t reboot the Hub it is not the reason for the lack of connection.

Until the VM Connect app works manage the Hub at

Forum Team
Forum Team

Hello cairns101,

Thanks for your post, Sorry to hear about the issue with the connect App.

The first thing to be aware of is you need to be connected to your Home Wi-Fi in order for the app to connect to the Hub. It won't allow the connection if you're on a different Wi-Fi network, Guest network on your own Wi-Fi, VPN, or mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that:


For your Apple device, if you're on iOS 15 then you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data.

If you're on iOS 16 then just delete the app from your device, restart the handset, and then re-download the Connect App. 


For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 


If this also fails then we currently have a known error with some of the data in our systems that's causing the app to not recognise the Hub in a minority of instances. We're already investigating this as a high priority.


Pop back and keep us posted. 



Hello. I tried all these steps myself to no avail. I upgraded to Hub 5 yesterday with the 360 package. All working fine except the VM connect app. I am guessing that it will resolve in due course 😉 

Hi there @Clagmeister 👋 Welcome back to our forum and thanks for your post 😊

Sorry to see you are also seeing this issue with the Connect app not connecting to your Hub 😔 Thanks for following the steps listed, apologies that these didn't help to resolve your issue.

The team are still investigating this issue that is affecting a small number of customers, they hope to have this issue resolved as soon as possible.

If you need any further help, please let us know. We're always happy to help.



The do's and don'ts. Keep the community welcoming for all. Follow the house rules

I am pleased to say everything seems to be working fine. Yesterday I decided to rename my network and this triggered a rebooting of my Hub 5 with the new settings which seems to have fixed the VM connect app problem