Showing results for 
Search instead for 
Did you mean: 

VM connect app and Hub 3

Tuning in

My VM Connect app cannot find my Hub 3.

When I first joined Virgin, it connected fine, but somewhere along the way it stopped. I have tried the reset button on the hub, tried powering down the hub, restarting my phone and un installing and reinstalling the app but still it cannot find the hub.

The daft thing is, I connect to the Internet via the hub on my phone, but I want to be able to connect with the app to control devices that are connected to the Internet via the hub.

Any suggestions? I'm out of ideas. 


Tuning in

Is your phone Android 12 or 13?


My Android 12 won't connect to hotspots on the new update, but an Android 11 phone I have does work

Thanks for the reply.

It's Android 10. Like I said, it worked to start with but now it doesn't. No hardware has changed, I assume it must have been a software update that's caused the issue. 

Hey brassmonkey001, thank you for reaching out and a warm welcome the community. I am sorry to hear about the connect app not picking up your HUB3.

How long has this not been working for?

You also say it's on / off when it does work, when was the last time it appeared?

Please can I just check the app and phone is fully updated to the latest software? Thanks 

Matt - Forum Team

New around here?

Thanks for the reply, 

It has been months since it worked, maybe six months or more. 

The app and phone software are all up to date. 

Hey brassmonkey001, thank you for letting me know this.

Please can you tell me what error message it gives you when you try and connect the app?

Does it give you any codes message such as 7400 for example. Thanks 

Matt - Forum Team

New around here?


it is doing the same to me. I have tried re starting the hub, my phone, uninstalled and reinstall the app but no joy. It just says it looks like we have lost connection try installing again. Have tried numerous times. The Wi-Fi works fine as everything is still connected and getting internet just the connect app. 

Issues issues issues, I have never tried the app as i have a Hub4, imagine my delight when the email drops today stating it now supports Hub4.......

......... er no it doesnt.

It cannot find it and wants to help me connect to my Hub 3 OR and i love this "help me to get one"  LMAO

Well I'm new to VM and VM community I left SKY after poor customer service and it seems there's issues with the connect app and by reading these comments the problem I'm having has been going on for month's.I've tried for the last 2 days trying to get me phone to connect to my hub3 using connect app.So can i ask you VM what are you doing about it????

Hi there all, 


I'm so sorry to hear that you are all also experiencing these issues. 


Can I ask if anyone of you are also using an Android 12 or 13?


Are your Apps also the most up to date versions? 


Thank you.