Menu
Reply
Highlighted
  • 2
  • 0
  • 0
Joining in
229 Views
Message 1 of 6
Flag for a moderator

TV connected to Ethernet not getting IP settings

Hi,

I have a HUB3 set up in modem mode as I have a mesh wifi system.  I want to connect a Smart TV via ethernet to the HUB but it's not getting a default gateway or DNS server IP.  The following are the IP settings the TV picks up when in modem mode:

IP address : 169.254.252.60

Subnet Mask : 255.555.0.0

Gateway : 0.0.0.0

DNS : 0.0.0.0

I've tried setting the Default Gateway and DNS manually by guessing what it might be but no joy.  I then tried changing the modem back to Router mode and it works OK on the ethernet connection.  I'm trying to find out if there is a way to operate the HUB in modem mode and have the ethernet working.

Any ideas?  Thanks.

0 Kudos
Reply
Highlighted
  • 2.52K
  • 183
  • 348
Superfast
227 Views
Message 2 of 6
Flag for a moderator

Re: TV connected to Ethernet not getting IP settings


@rich0056 wrote:

Hi,

I have a HUB3 set up in modem mode as I have a mesh wifi system.  I want to connect a Smart TV via ethernet to the HUB but it's not getting a default gateway or DNS server IP.  The following are the IP settings the TV picks up when in modem mode:

IP address : 169.254.252.60

Subnet Mask : 255.555.0.0

Gateway : 0.0.0.0

DNS : 0.0.0.0

I've tried setting the Default Gateway and DNS manually by guessing what it might be but no joy.  I then tried changing the modem back to Router mode and it works OK on the ethernet connection.  I'm trying to find out if there is a way to operate the HUB in modem mode and have the ethernet working.

Any ideas?  Thanks.


No, when in modem mode the HUB is no longer a router so will not supply an IP address to any devices plugged into the ethernet ports.

Highlighted
  • 2.13K
  • 133
  • 414
Problem sorter
205 Views
Message 3 of 6
Flag for a moderator

Re: TV connected to Ethernet not getting IP settings

Strictly speaking it will allocate a single WAN IP address to any connected network device. So you could get an IP address but only for one device. A 3rd party router will be required if using the Hub in Modem Mode for any other networking requirements.

Highlighted
  • 615
  • 37
  • 95
Rising star
185 Views
Message 4 of 6
Flag for a moderator
Helpful Answer

Re: TV connected to Ethernet not getting IP settings

You have two options here.

1. Connect your TV to an ethernet port on you main WiFi mesh gateway.
2. Put your SH3 in router mode and your WiFi mesh in bridge mode. You can then connect your TV to the SH3

0 Kudos
Reply
Highlighted
  • 6.28K
  • 463
  • 1.09K
Hero
181 Views
Message 5 of 6
Flag for a moderator

Re: TV connected to Ethernet not getting IP settings

What's the make and model of your mesh?

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG1008D 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
0 Kudos
Reply
Highlighted
  • 2
  • 0
  • 0
Joining in
124 Views
Message 6 of 6
Flag for a moderator

Re: TV connected to Ethernet not getting IP settings

Bit embarrassed that I didn't think to connect the TV to an ethernet port on the mesh!  Doh, thanks for the pointer, works perfectly 👌 

0 Kudos
Reply