Menu
Reply
Highlighted
  • 12
  • 0
  • 0
Tuning in
417 Views
Message 1 of 16
Flag for a moderator

Superhub3 issues for many if pfSense firewalls used

Hello,

These seems to be a common issue in the UK with many users with regards to using pfSense with Virgin Broadband. They use something called a Superhome Hub 3 that you can put into modem mode and cable into your pfSense device or virtual host.

https://www.reddit.com/r/PFSENSE/comments/gh6gdl/gateway_alarm_wan_dhcp_with_virgin_hub_router/

Some say it's to do with the Puma chipset the Virgin Superhub3 uses, but it's causing many issues for lots of people including me. It doesn't matter if you are virtual or physical either.

We have tried changing the thresholds and disabling GW monitoring, but still get the issue. It seems to happen more during video calls we have all found (Zoom/Teams).

If you restart the router & pfSense we have found it to work better for a day or 2.

Upgrading from 2.4.4 to 2.4.5 doesn't make any difference.

Some have started to use other FWs and they are better.

Any ideas would be great or any extra logging I can do and post.

Thanks

0 Kudos
Reply
Highlighted
  • 3.82K
  • 681
  • 988
Very Insightful Person
Very Insightful Person
407 Views
Message 2 of 16
Flag for a moderator

Re: Superhub3 issues for many if pfSense firewalls used

Hello

I have the hub 3 with the following details -

Hardware version: 10
Software version: 9.1.1811.401

 

Also running the latest pFSense running on a i5 2400s -

 
2.4.5-RELEASE (amd64)
built on Tue Mar 24 15:25:50 EDT 2020
FreeBSD 11.3-STABLE

 

What is the actual problem you are having ? as I have mine running pretty much 24/7, with pfsense / hub 3.0 reboots approx every 2 weeks and have no problems at all.

Regards Mike

 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
Highlighted
  • 13.94K
  • 574
  • 1.33K
Alessandro Volta
384 Views
Message 4 of 16
Flag for a moderator

Re: Superhub3 issues for many if pfSense firewalls used

setup a BQM
https://www.thinkbroadband.com/broadband/monitoring/quality

---------------------------------------------------------------
BQM, Test for outgoing ports and SSL/L2TP VPN test
0 Kudos
Reply
Highlighted
  • 95
  • 0
  • 14
Dialled in
364 Views
Message 5 of 16
Flag for a moderator

Re: Superhub3 issues for many if pfSense firewalls used

What use is BQM if no one from Virgin does anything with that info? The amount of high latency BQM posts in the last 2 weeks should be enough already.

Highlighted
  • 290
  • 8
  • 36
Superfast
321 Views
Message 6 of 16
Flag for a moderator

Re: Superhub3 issues for many if pfSense firewalls used

I have been using pfSense / Hub 3 for many years and it works great

amd 5350 APU 2.4.5 release. Currently 44 days since last boot.

getting 500 Mb without issue

Alpha SSL, HA proxy

openvpn road warrior, HE IPv6, Nord VPN tunnels.

All work as intended.

0 Kudos
Reply
Highlighted
  • 12
  • 0
  • 0
Tuning in
298 Views
Message 7 of 16
Flag for a moderator

Re: Superhub3 issues for many if pfSense firewalls used

I thought mine was fine until there was the lock down in the UK and we all had to work from home, it's mainly triggered on large conference calls like Zoom.

A restart of the SH3 always fixes things for a few days.

Is your pfSense box physical or a VM?

0 Kudos
Reply
Highlighted
  • 51
  • 0
  • 10
On our wavelength
295 Views
Message 8 of 16
Flag for a moderator

Re: Superhub3 issues for many if pfSense firewalls used

20th April (well into lockdown) was when it all started going wrong for me. 

https://community.virginmedia.com/t5/Networking-and-WiFi/Intermittent-packet-loss-high-latency-throu...

Firmware update, then it got progressively worse over 2-3 days. 

 

Can those with BQM check their results from 19th-24th April for each day and see if there's a worsening trend? 

My Broadband Ping - Home
Highlighted
  • 6
  • 0
  • 1
Tuning in
262 Views
Message 9 of 16
Flag for a moderator

Re: Superhub3 issues for many if pfSense firewalls used

I have been having these issues. I have just updated to pfsense 2.5.x development version which upgrades the version of the underlying OS (BSD 11 > BSD 12) and this seems to have solved my issue.
I believe there is a bug with the latest VM modem firmware when you are in modem mode.

Only upgraded a couple hours ago and connection is 100x times better. See the below BQM.

BQM Ping Graph

 

0 Kudos
Reply
Highlighted
  • 12
  • 0
  • 0
Tuning in
239 Views
Message 10 of 16
Flag for a moderator

Re: Superhub3 issues for many if pfSense firewalls used

This is interesting! Let's see how you get on.

I always find after the SH3 or pfSense is rebooted it's always better for a day or so.

How did you upgrade to 2.5.x Dev?
0 Kudos
Reply