Showing results for 
Search instead for 
Did you mean: 

Netflix Blocking Shows Due to 'Virgin Media'

Joining in

I wonder if anyone can help.

Basically, Netflix is Blocking shows due to them believing my network is using a Proxy or Is a VPN (It isn't) I have spoken to both Netflix and Virgin media and the response I got from Netflix was that

'It is on your network providers end.'
'And if your Network provider is using or distributing such a connection to their subscribers then we can't do anything about it.'

and the response from calling virgin media is just 10x better the person on the phone just told me that she can't do anything about it and to just change "settings"

I have tried getting a new IP but it's hard to do with Virgin Media and I don't really want to spend money on a router just to change my IP and watch Netflix for them to possibly block it. Its a bit of a odd situation because Virgin Media belives its Netflix and Netflix belives its my ISP




[MOD EDIT: We're collating more information about this. Please see this post and reply back to this thread thanks]


Accepted Solutions


Just wanted to post an update to this as our Support Team has come back and confirmed that everything is okay on our side. It may however be an issue at Netflix's end with recent changes they may have made and differences in certain setups with third party equipment, for example mesh systems. Netflix may work for while and then stop and in this instance you may need to renew your IP address 

We would advise that you temporarily try placing the Virgin Media Hub in modem mode only and see if you can access Netflix without using 3rd party equipment as a test. If you're able to access Netflix okay and wish to use your 3rd party equipment, you may try and switch the Hub between the modem and router modes and you may also try spoofing your MAC address to renew the IP address. Unfortunately we're unable to provide support for third party equipment but please consult the third party documentation for more information on how to do this.




See where this Helpful Answer was posted


Very Insightful Person
Very Insightful Person

It’s not VM’s fault. Netflix have put a block on your IP address and they are the only people who can remove it. Contact them again.

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

100% Netflix's issue!

Hub 3 - Modem Mode - TP-Link Archer C7

Maybe what happen is the IP you got someone else had who used a VPN to get US stuff Netflix seeing two IP's when not using a VPN blocked the VM IP and now you got the IP.


Very Insightful Person
Very Insightful Person

Hi JacobG01,

You should be able to check if it is an IP address issue by putting the VM hub into modem mode via the settings. It should give you a new IP address and then try connecting to Netflix again.

NB When you put your hub back into router mode you will be allocated your original IP address again.

  1. Open your Internet browser and log into the hub's settings page by entering into the address bar.
  2. Enter your Hub 3 settings password. The default password is on the bottom of the Hub 3.  If you have changed the default password, enter that password instead
  3. Once you've logged in, click Modem Mode on the left and  then in the screen that opens click the option to Enable Modem Mode and then click Apply changes

Rebooting your hub after that should set back into router mode, but if that fails log into  and follow the above instructions but click Enable Router Mode and Apply changes instead.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Very Insightful Person
Very Insightful Person
Just to add the "bleeding obvious" to newapollo's excellent response - when in modem mode there is no wifi - so you will need to connect the device you are using for netflix by ethernet cable nto the Hub after removing any other connections - as only one port is active in modem mode.


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

Joining in

Did you ever solve this. I have the same issue. 

Hi Phil7g, 

Thanks for your post and apologies to hear you are having the same issue. 

I would follow the advice given above by the users. We're not able to make any changes if Netflix have blocked your IP Address I'm afraid. This will be something they will need to unblock. 

Apologies once again. 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Tuning in

Hi I've had this issue for 3 weeks, keep losing our watch list for a few days, they then reappear for a few hours then disappear again, all on multiple WIFI devices and set top boxes, if we disconnect from WIFI we can view all our content .

numerous calls between VM and Netflix , each blaming each other, still not resolved

Netflix also said IOS mobile was connected to a proxy  or  VPN  at some point, disconnected every device just leaving 1 set top box (V6) connected, still the same.


Yes I have been having the exact same problem. Both VM and Netflix blamed each other and accused the other of lying.

Netflix says they detected a proxy/VPN and VM said that there categorically was no proxy/VPN.