Showing results for 
Search instead for 
Did you mean: 

Hub4 - 1gig speed decreased

On our wavelength

I have the same green light, in modem mode.

However, my 1gig service decreased massively to around 35Mbps post this update and have remained that way ever since 😥

Power levels look ok.

The virgin media broadband check says no issues in my area, but when it runs a connection test, it claims there is a complex local area fault (which coincidentally coincides with the firmware update!)

If the hub 4 is rebooted, it may take a couple of attempts to reconnect.



[MOD EDIT: Post split to create own thread]



Mikrotik rb4011 

Mine's is a Mikrotik CCR1009-7G-1C-1S+ which is connected to the Hub via four ethernet ports concurrently, although two worked just as well.

The key point is: whatever device you're using, it needs to support round-robin (balance-rr) rather than just static link aggregation for bonding to succeed.

I'll see if it continues to work after the firmware update lands, though.



This firmware update was finally delivered to my hub 4 on Thursday and now I'm in the same boat as the OP - bonded channels now limited to around 30Mb up and down, having consistently been at over 1100/50 for months. I wondered why my work connection has seemd to lag for the last few days. I'll try reducing to two LAN cables from four and reset the hub to see if this makes a difference, although I think I know the answer.

So, it look's like my time with VM is almost up, which is a pity since I've been with the company for over 20 years (Telewest, originally) but the better than gigabit downloads on the LAN side had been my main reason for staying with them... I like the look of the symetric 950Mb my colleague is getting over fibre.

I have just had this update as well. My speeds fell through the floor until I rebooted (full power off: plug out, count to 10, plug in).

I called to report the issue and was told that there was an area fault and that an engineer would have to visit.

Poor speeds after Firmware updatePoor speeds after Firmware update

Thanks for the info.

I can't see your image yet - do you use port bonding, or is there a general issue with low speeds until a hard reboot is carried out?

I did a (very) quick search on the wider web and, while others had reported the same issue previously, as far as I could see no-one had reported being able to get their speeds back to what they had been with bonding on.

I've switched to a single cable for now and have restarted my hub and I'm back up to around 900Mb, as expected, which means my work connection is properly usable again.

I'll do some more poking later on this evening and report back(I can hear the groans from around the house already...).

One promising sign was that prior to undoing the bond I had seen traffic over all four ports, albeit at a much lower speed than expected.

Here's a snippet from my speedtest history, for info.Speedtest_feb2023.png


I haven't been using port bonding and because the Hub is tucked away I hadn't seen the green light until this morning. It is difficult to find reliable 1Gb+ Speedtest sites in the UK so my maximum measured speed is 950Mb via my router (WRT32X running openwrt) to my hub operating in modem mode. My software update occurred on the 15-Feb-2023.

My software version is now AR01. (edit, added)

Thanks for this, I was updated to  AR01. on Sunday and it absolutely killed my connection. Removing the LAGG at least restored to 940Mb. I will try your reset in the hope the old firmware get reinstalled and I can get back full speed.

Hub4/Gig1-> pfSense->Microtik CRS312/CSS326/CRS305->Meshed Asus RT-AX89X
VM Network - Timwilky

>> I will try your reset in the hope the old firmware get reinstalled and I can get back full speed.

I doubt that's going to happen, unfortunately. I think it's a Hub 5 or nothing for >1Gb on the LAN side now, I'm afraid. If I can't get my old speeds back tonight I'll see if I can get my hands on one but, if not, I'll be off elsewhere.

Edit: incidentally, 940Mb is about the maximum you'll get on a single Gb LAN port due to protocol overheads, etc. which is why bonding (using round-robin aggregation) was so attractive to some of us.

I'm in the same boat too now. I was using bonding and getting max speed until yesterday. The hub 4 now has the green ring, and my speed was terrible. Reverting to a single cable has got the speed back up to 930/940mbps.

Quite disappointing that Virgin have done this considering it's near impossible to get a hub 5.

Hi inspectorgagjet


Sorry to hear of the speed issues since the firmware update, we appreciate you raising this via the forums.


We've tried to check your connection and equipment from our side but are limited to what we can see, it appears this is due to the hub being in modem mode which limits the information available.


if you would like us to look into this, please let us know when the Hub isn't in modem mode and we will be happy to take a look.