cancel
Showing results for 
Search instead for 
Did you mean: 

Hub 4 - modem mode - port forwarding

TimWardCam
Joining in

I've got a Hub 4 in modem mode, the router is a Vigor 2832n. Everything has been working fine for years, but now for the first time I'm trying to set up port forwarding.

Doesn't work. So far as I can see, whatever I set on the router the remote client gets an RST in response to its SYN.

I'm just wanting to confirm that I don't have to set anything up on the Hub 4 to get incoming TCP connections to work - if it's acting as a modem it's just passing all traffic straight through in both directions without even looking at it, let alone trying to block any of it, right?

1 ACCEPTED SOLUTION

Accepted Solutions

Adduxi
Very Insightful Person
Very Insightful Person

You are correct. Modem mode is just that, a bridge to the VM network.  Any and all work needs to be done via the Draytek Vigor. 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

See where this Helpful Answer was posted

9 REPLIES 9

Adduxi
Very Insightful Person
Very Insightful Person

You are correct. Modem mode is just that, a bridge to the VM network.  Any and all work needs to be done via the Draytek Vigor. 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

TimWardCam
Joining in

And guess what - that turns out to be WRONG.

It is necessary BOTH to set up port forwarding on the router AND to set up port forwarding on the hub. Then it works.

Really...what IP did you use for the hub port forwarding?

---------------------------------------------------------------

TimWardCam
Joining in

The 192.168.0.x address which the router said was its upstream address on its LAN connection. Thus

xxx.duckdns.org -> 81.x.x.x -> Hub 4 -> 192.168.0.x -> router -> 192.169.1.x

with port forwarding needed at both hub and router. Not what I was expecting, but it seems to work.

The HUB wasn't in modem mode as it uses IP address 192.168.100.1.

You also cannot access the port fowarding settings, as with the majority of others, when in modem mode.

Vinegar
Up to speed

Indeed, if you did really have the hub in ‘modem mode’, (bridge mode would technically be more accurate), there are no options to do any sort of port forwarding. Although no, it doesn’t use 192.168.100.1, that’s a bit of a misconception, this address is just a ‘management address’ it plays no part in the routing.

I’m afraid to say that the OP’s opening statement is WRONG, the hub isn’t in modem mode.

TimWardCam
Joining in

The installer said he set the hub to modem mode. The hub seems to say it's in modem mode - the option it offers me is to switch out of modem mode. They're both lying?

If it's in modem mode you should not be able to access the port forwarding settings.

Note the sections available on the left:

TimWardCam
Joining in

So ... the installer was lying to me, had managed to turn off wifi and somehow made the hub look to the router like a modem, but without actually putting it into modem mode, and the user interface, given my mindset of believing the installer, is a bit confusing? Hmm. Anyway, it's all working now.