Menu
Reply
njhaigh
  • 7
  • 0
  • 0
Tuning in
4,644 Views
Message 1 of 12
Flag for a moderator

Hub 3 not working in Modem Mode

I have 350mbps fibre from Virgin and have the Hub 3. Wi-Fi on these units are ridiculously poor so I purchased a TP-Link Deco M4 Mesh system with 3 nodes. 1 connected directly to the Virgin hub then the other 2 on separate floors connects to the main Deco unit.
Ideally you set the Virgin hub into modem mode and the Deco’s take care of the rest.
But the moment I set the hub settings into modem mode, it kicks me out and can’t log back in again (using the default factory password etc) I then lose all internet. I cave no internet even hard wired into the virgin box with Ethernet. The only way I get any internet is to still have the Virgin hub in router mode.

But I am only reaching speeds of 100mbps through the Deco’s which are supposed to be capable of greater speeds than the package I am on with Virgin.

I have read a lot of tips etc in many forums as other have experiences the same but they seem to get theirs fixed with a simple change of QoS settings in the Deco app, changing from a cap or 100mbps to 1000mbps. But they are also able to access the modem mode on the hub, which I cannot. 

0 Kudos
Reply
jbrennand
  • 33.7K
  • 3.3K
  • 6.41K
Very Insightful Person
Very Insightful Person
4,629 Views
Message 2 of 12
Flag for a moderator

Re: Hub 3 not working in Modem Mode

Change the ethernet cable connecting the Deco with a new Cat5e/6/7 one (it may have "failed".

Then try the set up again in this way ..
_______________________________________________________________

There's a quirk with the deco line that means you have to do the initial setup of the first deco unit whilst connected to the hub when it is in router mode, did you do this?

If not, put the hub back into router mode, get the first deco online and registered in the app, then do this.

In the first Deco's settings, set it to be with the WAN port set to be in Automatic IP i.e. DHCP (& Nat) mode, it may be pre-set that way anyway. Then, disconnect all cables from your Deco units and switch them off and unplug them.

Then, put the VM Hub into modem mode
( https://www.virginmedia.com/help/virgin-media-hub-modem-mode )
and leave it for 5' for the base light to turn magenta/purple (on a Hub3 - but not on a Hub4!).

Once it’s in modem mode, the VM hub “MUST” then be powered off. Switch your First Deco on and make sure it’s fully initialised (leave 5 min)..... and then put in the ethernet cable from its WAN port to the VM hub (any port will do).

NOW… power up the VM hub and wait 5-10 minutes for The Hub to initialise and and you should get a connection. Use the recommended App to connect any other Mesh units to the first one. This order only needs to be done the first time you connect the router to the VM hub.


--------------------
John
--------------------

I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router +2 Airport Express's. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
njhaigh
  • 7
  • 0
  • 0
Tuning in
4,621 Views
Message 3 of 12
Flag for a moderator

Re: Hub 3 not working in Modem Mode

I tried various Ethernet cables yes. (Purchased) New and old 

 

0 Kudos
Reply
legacy1
  • 19.57K
  • 800
  • 2.07K
Alessandro Volta
4,609 Views
Message 4 of 12
Flag for a moderator

Re: Hub 3 not working in Modem Mode

Disable or change wifi password on the Deco connect a PC to the Deco and only Deco in router mode to hub change to modem mode unplug PC power off hub for 2mins power turn wait 5mins then unplug Deco Ethernet to hub and plug back in then connect a PC enable wifi.

---------------------------------------------------------------
0 Kudos
Reply
njhaigh
  • 7
  • 0
  • 0
Tuning in
4,581 Views
Message 5 of 12
Flag for a moderator

Re: Hub 3 not working in Modem Mode

 


@jbrennand wrote:

Change the ethernet cable connecting the Deco with a new Cat5e/6/7 one (it may have "failed".

Then try the set up again in this way ..
_______________________________________________________________

There's a quirk with the deco line that means you have to do the initial setup of the first deco unit whilst connected to the hub when it is in router mode, did you do this?

If not, put the hub back into router mode, get the first deco online and registered in the app, then do this.

In the first Deco's settings, set it to be with the WAN port set to be in Automatic IP i.e. DHCP (& Nat) mode, it may be pre-set that way anyway. Then, disconnect all cables from your Deco units and switch them off and unplug them.

Then, put the VM Hub into modem mode
( https://www.virginmedia.com/help/virgin-media-hub-modem-mode )
and leave it for 5' for the base light to turn magenta/purple (on a Hub3 - but not on a Hub4!).

Once it’s in modem mode, the VM hub “MUST” then be powered off. Switch your First Deco on and make sure it’s fully initialised (leave 5 min)..... and then put in the ethernet cable from its WAN port to the VM hub (any port will do).

NOW… power up the VM hub and wait 5-10 minutes for The Hub to initialise and and you should get a connection. Use the recommended App to connect any other Mesh units to the first one. This order only needs to be done the first time you connect the router to the VM hub.





Yes tried this, these were the first steps I did when I got the Deco, I read up on how to set these up, but like I mentioned, my setup has not gone 

like others have, as soon as I put the virgin hub in modem mode, it kicks me out and can't log back in, with no internet (even after restarting everything)

 

 

0 Kudos
Reply
njhaigh
  • 7
  • 0
  • 0
Tuning in
4,579 Views
Message 6 of 12
Flag for a moderator

Re: Hub 3 not working in Modem Mode


@legacy1 wrote:

Disable or change wifi password on the Deco connect a PC to the Deco and only Deco in router mode to hub change to modem mode unplug PC power off hub for 2mins power turn wait 5mins then unplug Deco Ethernet to hub and plug back in then connect a PC enable wifi.


I haven't tried connecting a pc (in my case Mac) to the Deco, I have been connecting it via ethernet directly to the virgin hub, so I will try this step but like I mentioned, as soon as I switch the hub into modem mode, it logs you out, I can't log back in again as it says the password is incorrect (even though it is correct), I also lose internet (but not tried with it connected to a Deco)

Thanks

0 Kudos
Reply
newapollo
  • 14.12K
  • 1.89K
  • 4.34K
Very Insightful Person
Very Insightful Person
4,523 Views
Message 7 of 12
Flag for a moderator

Re: Hub 3 not working in Modem Mode


@njhaigh wrote:

@legacy1 wrote:

Disable or change wifi password on the Deco connect a PC to the Deco and only Deco in router mode to hub change to modem mode unplug PC power off hub for 2mins power turn wait 5mins then unplug Deco Ethernet to hub and plug back in then connect a PC enable wifi.


I haven't tried connecting a pc (in my case Mac) to the Deco, I have been connecting it via ethernet directly to the virgin hub, so I will try this step but like I mentioned, as soon as I switch the hub into modem mode, it logs you out, I can't log back in again as it says the password is incorrect (even though it is correct), I also lose internet (but not tried with it connected to a Deco)

Thanks


If you are in modem mode then only one ethernet port will work on the VM hub, and that's the port you connect your Deco to.

When you are in modem mode you have to log into the VM hub using 192.168.100.1 - when logging into the hub you use the Settings password and not the WiFi password.

Dave

The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali


I don't work for Virgin Media.

I'm a Very Insightful Person, I'm here to share knowledge. Learn more

Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks

The do's and don'ts. Keep the community welcoming for all. Follow the house rules
njhaigh
  • 7
  • 0
  • 0
Tuning in
4,506 Views
Message 8 of 12
Flag for a moderator

Re: Hub 3 not working in Modem Mode

Thank you

I have now managed to switch to modem mode, log back in using 192.168.100.1

so that's all good, but I am still only getting 195mbps d/l on wifi but ethernet I get the full 350mbps d/l

any suggestions?

The Deco M4 mesh system specs are:

The Deco M4 is a dual-band AC1200 router, so it can reach speeds up to 1200 Mbps total between its two bands — 5 GHz and 2.4 GHz. This works out to an 867 maximum on the 5 GHz band and 300 on the 2.4 GHz.

 

I have changed the QoS settings on the Deco's to 1000 instead of the default 100, I have also swapped out the main deco for the other 2 to see if the ports may be faulty, but all achieve the same speeds connected directly to the vm hub

 

0 Kudos
Reply
legacy1
  • 19.57K
  • 800
  • 2.07K
Alessandro Volta
4,495 Views
Message 9 of 12
Flag for a moderator

Re: Hub 3 not working in Modem Mode

Looking for Wifi speed is always disappointing If you want more speed both ends must support faster speeds you will not get 100% of the claimed speeds.

Maybe look for a better AP.
---------------------------------------------------------------
0 Kudos
Reply
njhaigh
  • 7
  • 0
  • 0
Tuning in
4,466 Views
Message 10 of 12
Flag for a moderator

Re: Hub 3 not working in Modem Mode

Thank you, yes I understand it will never be 100% speed achieved through Wi-Fi but (roughly) 57%? Surely I should be getting more than that?

Like I previously mentioned, the Deco mesh system supports greater speed (hence why buying them) and pretty sure the Virgin hub is capable of greater speeds? 

not sure I want to shell out more money in the hopes of a faster connection but to be let down as I have so far, or spending a lot of money only to gain a little more speed. But I will take a look at this option, Dreytek has always been highly recommended? 

thank you 

0 Kudos
Reply